If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mozilla::storage::Service::Observe crash

RESOLVED INVALID

Status

()

Toolkit
Storage
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: Andriy Gapon, Unassigned)

Tracking

25 Branch
x86_64
FreeBSD
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; FreeBSD amd64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131125213802

Steps to reproduce:

Exited firefox.


Actual results:

Firefox crashed:
#0  thr_kill () at thr_kill.S:3
#1  0x00000008032c8a27 in nsProfileLock::FatalSignalHandler (signo=11, info=<optimized out>, context=0x7fffffffc520)
    at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/obj-x86_64-unknown-freebsd11.0/toolkit/profile/nsProfileLock.cpp:180
#2  0x0000000800f90596 in handle_signal (actp=<optimized out>, sig=11, info=0x7fffffffc890, ucp=0x7fffffffc520) at /usr/src/lib/libthr/thread/thr_sig.c:237
#3  0x0000000800f9013f in thr_sighandler (sig=11, info=0x0, _ucp=0x7fffffffc520) at /usr/src/lib/libthr/thread/thr_sig.c:182
#4  <signal handler called>
#5  0x0000000804b9b56c in mozilla::storage::Service::Observe (this=0x818fdfd00, aTopic=<optimized out>) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/storage/src/mozStorageService.cpp:925
#6  0x0000000805582f7a in nsObserverList::NotifyObservers (this=<optimized out>, aSubject=aSubject@entry=0x0, aTopic=aTopic@entry=0x806407fb2 "xpcom-shutdown-threads", someData=someData@entry=0x0)
    at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/xpcom/ds/nsObserverList.cpp:99
#7  0x00000008055841d0 in nsObserverService::NotifyObservers (this=0x8168bc600, aSubject=aSubject@entry=0x0, aTopic=aTopic@entry=0x806407fb2 "xpcom-shutdown-threads", someData=someData@entry=0x0)
    at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/xpcom/ds/nsObserverService.cpp:161
#8  0x00000008055688d5 in mozilla::ShutdownXPCOM (servMgr=0x8017e2348) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/xpcom/build/nsXPComInit.cpp:664
#9  0x00000008032b1e01 in ScopedXPCOMStartup::~ScopedXPCOMStartup (this=0x8017226e0, __in_chrg=<optimized out>) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/toolkit/xre/nsAppRunner.cpp:1130
#10 0x00000008032bc88b in XREMain::XRE_main (this=this@entry=0x7fffffffcc70, argc=argc@entry=3, argv=argv@entry=0x7fffffffd3d8, aAppData=aAppData@entry=0x7fffffffcf40)
    at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/toolkit/xre/nsAppRunner.cpp:3951
#11 0x00000008032bcb1c in XRE_main (argc=3, argv=0x7fffffffd3d8, aAppData=0x7fffffffcf40, aFlags=<optimized out>) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/toolkit/xre/nsAppRunner.cpp:4128
#12 0x0000000000403890 in do_main (xreDirectory=0x801755a80, argv=0x7fffffffd3d8, argc=3) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/browser/app/nsBrowserApp.cpp:275
#13 main (argc=<optimized out>, argv=<optimized out>) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/browser/app/nsBrowserApp.cpp:636
(Reporter)

Comment 1

4 years ago
(gdb) fr 5
#5  0x0000000804b9b56c in mozilla::storage::Service::Observe (this=0x818fdfd00, aTopic=<optimized out>) at /usr/obj/ports/usr/ports/www/firefox/work/mozilla-release/storage/src/mozStorageService.cpp:925
925               MOZ_CRASH();
(gdb) list
920         if (gShutdownChecks == SCM_CRASH) {
921           nsTArray<nsRefPtr<Connection> > connections;
922           getConnections(connections);
923           for (uint32_t i = 0, n = connections.Length(); i < n; i++) {
924             if (connections[i]->ConnectionReady()) {
925               MOZ_CRASH();
926             }
927           }
928         }
929       }
(gdb)

Updated

4 years ago
Component: Untriaged → Storage
Product: Firefox → Toolkit
(Reporter)

Comment 2

4 years ago
Looks like this was caused by a defect in a cutting edge kernel that I used.
The defect caused swapped out pages to become zeroed out under some very specific conditions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.