Regression: Throbber sticks around frozen on screen when conducting a Google Search; favicon does not replace throbber

RESOLVED FIXED in Firefox 28

Status

()

Firefox for Android
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aaronmt, Assigned: rnewman)

Tracking

({regression, reproducible})

28 Branch
Firefox 28
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox27 unaffected, firefox28 fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8339297 [details]
Nightly (11/27) - Screenshot

Currently when one conducts a Google Search, the throbber sticks around and the favicon does not appear at all.

So far for whatever reason I am only able to reproduce through long-tap, 'Google Search' with selected text.

Tap test-case URL, long tap on selected text and open the dotted menu and select 'Google Search'.

See screenshot.

--
Nightly (11/27) | LG Nexus 4 (Android 4.4)
(Reporter)

Comment 1

4 years ago
Regression from bug 941868.
Blocks: 941868
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

4 years ago
Also seeing this on tab restoration of Google searches
(Reporter)

Comment 3

4 years ago
D/GeckoToolbar( 9024): onTabChanged: STOP
D/GeckoToolbar( 9024): setProgressVisibility: false
D/GeckoToolbar( 9024): setFavicon(null)
D/GeckoToolbar( 9024): Ignoring favicon set: new favicon is identical to previous favicon.
I/GeckoToolbar( 9024): zerdatime 3875233 - Throbber stop
I think we are returning early from setFavicon because the incoming image is null and the mLastFavicon is null. We should be setting the favicon to a null drawable.
I can repro using the STR
(Assignee)

Updated

4 years ago
Assignee: nobody → rnewman
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
I believe this is fixed by my partial backout and partial re-land in Bug 941868.

The issue was not the de-bouncing; it was that restored tabs (and certain other situations) send an almost-non-overlapping set of messages, and the logic I'd changed to do less work thus caused us to do... no work.

Aaron, please verify when that hits Nightly again!
(Assignee)

Updated

4 years ago
Duplicate of this bug: 943887
(Reporter)

Comment 8

4 years ago
Fixed via 941868.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
No longer blocks: 941868
status-firefox28: affected → fixed
Depends on: 941868
Target Milestone: --- → Firefox 28
tracking-fennec: ? → ---
status-firefox27: --- → unaffected
You need to log in before you can comment on or make changes to this bug.