Closed Bug 943882 Opened 11 years ago Closed 11 years ago

APZC can overscroll content

Categories

(Core :: Panning and Zooming, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 947337

People

(Reporter: vingtetun, Assigned: BenWa)

References

Details

With APZ turned on there is a few places where it seems like we overscroll content.

It is more easily reproducible on the settings app.

Steps to reproduce:
 - Open the settings app
 - scroll to the bottom and quickly scroll to the top, letting kinetic panning scrolls

Expected result:
 - The scroll stops when the list reach the top

Actual result:
 - The scroll seems to continue over the list limit and the content is slowly replace by a opaque black.

It does not reproduce all the time and I need often multiple tries to trigger it.
Also when it happens I see the vertical scrollbar slowly going down, which seems to indicate that the list size is growing while the scroll is ongoing.
Either a dupe or blocks bug 940706
Assignee: nobody → bgirard
Flags: needinfo?(nhirata.bugzilla)
(In reply to Milan Sreckovic [:milan] from comment #2)
> Either a dupe or blocks bug 940706

I have an hard time to reproduce it on Settings now. But I can reproduce it on one of the everything.me collection. I'm using Games and load all the content, then I can reproduce again.
(In reply to Vivien Nicolas (:vingtetun) (:21) (RTO - Review Time Off until 09/12/13) from comment #3)
> (In reply to Milan Sreckovic [:milan] from comment #2)
> > Either a dupe or blocks bug 940706
> 
> I have an hard time to reproduce it on Settings now. But I can reproduce it
> on one of the everything.me collection. I'm using Games and load all the
> content, then I can reproduce again.

With the patches from bug 944047 it seems like I can't reproduce the issue anymore. So I think Cwiis assumption that BrowserElementPanning.js can interact weirdly with APZ at some point may be correct.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Seems like I can reproduce it with all the latest patches. This is not easy but with various variation of speed I can see it in settings. Most of the time this is when I switch from one direction to an other. So top -> bottom -> top when the app is scrolled to the top.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Flags: needinfo?(nhirata.bugzilla)
You need to log in before you can comment on or make changes to this bug.