Code timeout into contacts_settings.tap_import_from_sim()

RESOLVED INVALID

Status

defect
P4
normal
RESOLVED INVALID
6 years ago
3 years ago

People

(Reporter: zcampbell, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=py])

Attachments

(1 attachment)

46 bytes, text/x-github-pull-request
Bebe
: review+
AndreiH
: review+
Details | Review
The 
self.wait_for_element_not_displayed(*self._loading_overlay_locator)

needs to be overridden to use a larger timeout because if the command line timeout is set to <10seconds then this wait does not wait for long enough.

Please run the test importing 5-10 contacts and judge how much time it will need. Accomodate for slower hardware/speed, don't be afraid to be generous with the timeout.
Assignee: nobody → viorela.ioia
Assignee: viorela.ioia → nobody
This could be (number_of_contacts_on_sim * default timeout) for example.
Whiteboard: [mentor=zac][mentor=bebe][lang=py]
Also please do the same in test_ftu_skip_tour.py
Assignee: nobody → robert.chira
Posted file Pull request
Attachment #8407571 - Flags: review?(zcampbell)
Attachment #8407571 - Flags: review?(florin.strugariu)
Attachment #8407571 - Flags: review?(andrei.hutusoru)
Attachment #8407571 - Flags: review?(andrei.hutusoru) → review+
Zac is the `self.marionette.timeout` the right timeout to use here?
Flags: needinfo?(zcampbell)
Yes that's right correct timeout Bebe.
Flags: needinfo?(zcampbell)
Attachment #8407571 - Flags: review?(zcampbell)
Attachment #8407571 - Flags: review?(florin.strugariu)
Attachment #8407571 - Flags: review+
Reverted:
https://github.com/mozilla-b2g/gaia/commit/cc1f1a807d0e3ce0437310a28e71501d720b4b3d

The passed-in time is not converted to seconds.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Duplicate of this bug: 1002993
This revert found a bigger issue in our test framework 
Bug 949543 - Use seconds for defining time in Marionette Python client

Let's fix this bug first and then this one
Depends on: 949543
Mentor: zcampbell florin.strugariu
Mentor: florin.strugariu, zcampbell
Whiteboard: [mentor=zac][mentor=bebe][lang=py] → [lang=py]
Mentor: florin.strugariu, zcampbell
QA Whiteboard: [fxosqa-auto-backlog+]
Assignee: robert.chira → nobody
is this bug still active, I am under the impression firefox os is not an active project anymore.
Pretty sure it isn't.
Status: REOPENED → RESOLVED
Closed: 5 years ago3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.