cannot allocate an object of abstract type 'android::GonkBufferQueue'

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: davidepucci21, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

log
6.82 KB, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 8339333 [details]
log

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.57 Safari/537.36

Steps to reproduce:

I just compiled B2G.
Once it arrives to gecko module, it fails.


Actual results:

Error:
../../../../../../../../../gecko/widget/gonk/nativewindow/GonkNativeWindowJB.cpp:37:46: error: cannot allocate an object of abstract type 'android::GonkBufferQueue'
Davide, can you explain more about your build environment and b2g build setting?
Flags: needinfo?(davidepucci21)
(Reporter)

Comment 2

5 years ago
OS: Antergos (Arch) 64bit. Completely set to compile, as for B2G (seen on Mozilla website the dependencies needed), as for Android.

Compiled for LG 4X HD p880. It correctly builded B2G for a long time, and I was fixing boot issues. Then, this error compared as another one for gecko/dom/bluetooth/BluetoothServiceBluedroid.cpp that now has been moved to gecko/dom/bluetooth/bluedroid/gonk/BluetoothServiceBluedroid.cpp (line 629).

These errors compared in a day, and now I always have them.
They compared while I was on on Ubuntu, that I test the 'booting' builds with. 

Do you need something else?
Flags: needinfo?(davidepucci21)
In attachment 8339333 [details], there is a following log, it seems the cause of the build failure.

------------------------------------

../../../../../../../../../gecko/widget/gonk/nativewindow/GonkBufferQueue.h:47:7: note:   because the following virtual functions are pure within 'android::GonkBufferQueue':
In file included from ../../../../../../../../../gecko/widget/gonk/nativewindow/GonkBufferQueue.h:25:0,
                 from ../../../../../../../../../gecko/widget/gonk/nativewindow/GonkConsumerBase.h:27,
                 from ../../../../../../../../../gecko/widget/gonk/nativewindow/GonkNativeWindowJB.h:27,
                 from ../../../../../../../../../gecko/widget/gonk/nativewindow/GonkNativeWindowJB.cpp:23:
../../../../../../../../../frameworks/native/include/gui/IGraphicBufferProducer.h:209:22: note: 	virtual android::status_t android::IGraphicBufferProducer::setBuffersSize(int)
../../../../../../../../../frameworks/native/include/gui/IGraphicBufferProducer.h:213:22: note: 	virtual android::status_t android::IGraphicBufferProducer::updateBuffersGeometry(int, int, int)
Your IGraphicBufferProducer seems to have following virtual functions. In andorid JB4.3 AOSP source does not have these functions.
- virtual android::status_t android::IGraphicBufferProducer::setBuffersSize(int)
- virtual android::status_t android::IGraphicBufferProducer::updateBuffersGeometry(int, int, int)
(Reporter)

Comment 5

5 years ago
Thanks, something was edited by me and messed up the things.

(I just had to reswitch to official Mozilla-b2g frameworks_native sources)
(Reporter)

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.