Update Presentations page of Mozilla Styleguide

VERIFIED FIXED

Status

www.mozilla.org
Pages & Content
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: sgarrity, Assigned: Stephen DesRoches)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

4 years ago
Creating a new bug to track the change requested in part 2 of comment #9 of Bug 930212.

Here's what John wrote:

> 2. Updating the presentations page (http://www.mozilla.org/en-US/styleguide/communications/presentations/) with new content. This one is more involved, but also long overdue, so will be great to get it fixed. Currently the page features a single template - the basic Sandstone theme - but we've since added two official Firefox OS templates that should be included as well.
> 
> Here's my suggested solution: remove the color options and layouts section from the current page, and instead show a row of three thumbnails (adding two more to the one that's there now). You can get the new templates from https://www.dropbox.com/sh/xgjn9as1qonv1ck/UYoxKryOSj (I'll make sure they're added to the assets repo and will post the links when they are).
> 
> To simplify the naming, the first one can be called Standard Sandstone, the next Firefox OS and the last Firefox OS (for developers). The two Firefox OS templates don't have HTML versions...only ppt and key for now.
>
> Last thing - we now also have a Google docs version of the Sandstone template. Can you add a 4th button to that arrangement and point to https://docs.google.com/presentation/d/1SGYCP7KG4C6IInNme5Wny4Bz0iFiI7lg9enELxdKUvQ/edit#slide=id.p40?

John, can you update this bug when the new Presentation files get added to the assets repo? Thanks.
(Reporter)

Updated

4 years ago
Flags: needinfo?(jslater)
(Reporter)

Comment 1

4 years ago
Some bad quoting syntax is causing line-wrap issues in bugzilla. Here's what John wrote again:

======================
Here's my suggested solution: remove the color options and layouts section from the current page, and instead show a row of three thumbnails (adding two more to the one that's there now). You can get the new templates from https://www.dropbox.com/sh/xgjn9as1qonv1ck/UYoxKryOSj (I'll make sure they're added to the assets repo and will post the links when they are).

To simplify the naming, the first one can be called Standard Sandstone, the next Firefox OS and the last Firefox OS (for developers). The two Firefox OS templates don't have HTML versions...only ppt and key for now.

Last thing - we now also have a Google docs version of the Sandstone template. Can you add a 4th button to that arrangement and point to https://docs.google.com/presentation/d/1SGYCP7KG4C6IInNme5Wny4Bz0iFiI7lg9enELxdKUvQ/edit#slide=id.p40?
======================
(Reporter)

Updated

4 years ago
Summary: add new pages & content to the FxOS section of the One Mozilla style guide → Update Presentations page of Mozilla Styleguide
(Assignee)

Comment 3

4 years ago
John: This is setup for review. 
https://www-demo1.allizom.org/en-US/styleguide/communications/presentations/

Can you confirm which assets I should be linking to? There are both standard and widescreen versions. Should there be two keynote buttons and two pptx buttons for Firefox OS?

Sandstone
-- widescreen.key
-- widescreen.ppt
-- standard.ppt

Firefox OS
-- widescreen.key
-- widescreen.pptx
-- standard.key
-- standard.pptx

Firefox OS Dev
-- standard.key
-- standard.potx

Is this the link for Sandstone HTML? https://github.com/codepo8/mozilla-presentation-templates

Comment 4

4 years ago
Hmm. Great point. I'd forgotten about the fact that we have multiples for each now. Having two buttons for each file type seems confusing. I suppose we could just have one button for each template and let people choose the file type they need when they get to the repo. What do you think?

Also, that's the correct link for the HTML template, yes.

Last thing: can you pick a more representative screenshot for the two Firefox OS templates? Right now they look almost identical.
(Assignee)

Comment 5

4 years ago
I have each with a single button. The screenshots were the first slide from each and the Dev file only had one page. Would picking a secondary page for Firefox OS work better? 

http://stage2.silverorange.com:8000/en-US/styleguide/communications/presentations/

Comment 6

4 years ago
Thanks Steven. I like the button treatment, and switching the FxOS one to orange makes them look different enough that I think the developer one is fine now.

This looks ready to push live to me.

Updated

4 years ago
Duplicate of this bug: 945989
(Reporter)

Comment 8

4 years ago
Pull request is here: https://github.com/mozilla/bedrock/pull/1475

This will go out once it has gone through code review. We'll update the bug.
fixed on stage https://www.allizom.org/en-US/styleguide/communications/presentations/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.