Long URLs are not broken at convenient lengths in Developer Console

RESOLVED DUPLICATE of bug 903676

Status

()

Firefox
Developer Tools: Console
P3
normal
RESOLVED DUPLICATE of bug 903676
5 years ago
2 years ago

People

(Reporter: Rob Crowther, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

28 Branch
All
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8339476 [details]
Screenshot of the console with the long URLs in warnings

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131127030201

Steps to reproduce:

I am debugging an ASP.Net application, this has some JavaScript baked into it which uses deprecated sourceMappingURL pragmas which leads to warnings in the console.  The warnings contain some very long URLs.


Actual results:

The long URLs force the console to approximately 4000 pixels width.


Expected results:

Console output should wrap at less than the window width so that shortcuts for leaping to the source code in the debugger are always visible.
Component: Untriaged → Developer Tools: Console
Hardware: x86_64 → All
Thanks for the bug report. In bug 663370 we want to turn those kind of URLs into clickable links. We should also limit their length.
Blocks: 778766
Status: UNCONFIRMED → NEW
Depends on: 663370
Ever confirmed: true
Priority: -- → P3

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 903676
You need to log in before you can comment on or make changes to this bug.