modified background image doesn't update on reload

VERIFIED DUPLICATE of bug 95981

Status

()

Core
ImageLib
--
trivial
VERIFIED DUPLICATE of bug 95981
17 years ago
17 years ago

People

(Reporter: Eric Weese, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
BuildID:    2001080110

When the background image on a page is modified, and the page reloaded, the old 
background image still shows up, even if the cache preference is set to "Every 
time".

Reproducible: Always
Steps to Reproduce:
1.Make a CSS file with BODY { background-image: url("image.gif") }, and make 
sure that image.gif exists
2.Link to it from an HTML document
3.Load the page in mozilla
4.On the computer's filesystem, rename some new image file to "image.gif", 
overwriting the original image
5.Reload the page in mozilla

Actual Results:  The original image appeared again.

Expected Results:  The new image should have appeared.

Only happens with background images.  Normal images refresh fine.

Comment 1

17 years ago
image lib?

Comment 2

17 years ago
Yes. Let's start with ImgLib.
Assignee: gordon → pavlov
Component: Networking: Cache → ImageLib
QA Contact: tever → tpreston

Comment 3

17 years ago
Can we get a testcase for this bug?

Comment 4

17 years ago
Looks like dup of bug 95981, fixed on the trunk on Aug. 24th.

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 95981 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.