Up & Coming themes should have at least 100 users

VERIFIED FIXED in 2014-08

Status

addons.mozilla.org Graveyard
Public Pages
P2
normal
VERIFIED FIXED
4 years ago
2 years ago

People

(Reporter: amyt, Assigned: davidbgk)

Tracking

unspecified
2014-08
x86
Mac OS X

Details

(Whiteboard: [contribute])

(Reporter)

Description

4 years ago
I don't know the exact algorithm for Up & Coming themes, but in the past a theme needed to have at least 100 users to get onto the list. In this screenshot, Abstrakt 07 has 77 users: http://i.imgur.com/FBxQbtj.png
Severity: normal → minor
Priority: -- → P5
Whiteboard: [contribute]
(Reporter)

Comment 1

3 years ago
Let's bump up the priority for this. There are designers who feel it isn't fair for themes that have fewer than 100 users to be on this list. http://i.imgur.com/kmP3XpU.png
Severity: minor → normal
Priority: P5 → P2
Target Milestone: --- → 2014-08

Updated

3 years ago
Assignee: nobody → yboniface
PR: https://github.com/mozilla/olympia/pull/185
Jason, I would love your expertise on the query plan effects introduced by this change.
You can find here the actual indexes on the table, and two explains on the request, one before the change, one after: https://github.com/mozilla/olympia/pull/185#issuecomment-51453364
Thanks :)
Flags: needinfo?(jthomas)
CC'ing :sheeri as she is better at this than I am :)
Flags: needinfo?(jthomas)
updated the comments at github, the gist is that adding an index changed things because it rebuilt the table (defragged/updated optimizer stats) so the popularity index didn't change anything.
Fixed in https://github.com/yohanboniface/olympia/commit/1da554ca942a9fea9fcabb96f2afd9e9965d7167
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED

Comment 7

3 years ago
When themes are sorted by Up & Coming, and only the themes that have at least 100 users are displayed, the page navigation should be updated accordingly. 

For example, the Causes Up & Coming themes only have 3 pages of themes with over 100 users https://addons.allizom.org/en-US/firefox/themes/causes?sort=up-and-coming&page=3 , therefore if we click page 4, "No themes found" error is displayed.
Please see screencast http://screencast.com/t/UoyyuKbKP
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

3 years ago
Assignee: yboniface → david
(Assignee)

Comment 8

3 years ago
PR: https://github.com/mozilla/olympia/pull/213
(Assignee)

Comment 9

3 years ago
We're facing performance issues with that new feature when computing the pagination. I see 4 options:

* Do not implement that filtering based on popularity and keep it as-is
* Set a static number of pages for the pagination (let's say 10 for instance) but it'll probably produce some issues on testing against dev/stage when there are less than 10 pages of up-and-coming addons
* Find a programmatic way full of complexity and denormalization
* Buy new servers :)

Thoughts?
Flags: needinfo?(atsay)
I would go on limiting the number of pages for all the sorts (now we have 12051 pages, which seems like 12000 or so useless pages ;) ).
And as we are talking about optimization, a hard coded number of pages doesn't seem the worst scenario to me. Maybe add a setting to let local/dev/stage have a lower number of pages.
Also, given that we are close to the push time, I suggest to revert from master for now, to give all people interested in this issue a bit more time to decide the good way to go (for example, if we decide to limit the number of pages, I don't think we can decide this without a green light from jorgev or someone from the product).

I'm planning to revert in 30 min from now if I've not opposite order. :)
Let's limit the view to 10. thanks.
(Assignee)

Comment 13

3 years ago
https://github.com/mozilla/olympia/commit/7fee48efd81ca31c1346cdefd9a219c920523217

QA, the default hard-coded number of pages for personas sorted by "Up & coming" is 10 in production, 5 on stage and 2 on dev, you'll not be able to paginate further than that anymore and no effort is done in trying to do not display the pagination if there aren't enough personas. There are way enough personas in production to fill the 10 pages.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(atsay)
Resolution: --- → FIXED

Comment 14

3 years ago
On stage, I see 5 pages. I'll let Iulian verify this since he initially reopened it

Comment 15

3 years ago
Verified as fixed in https://addons.allizom.org/en-US/firefox/themes/ and https://addons.mozilla.org/en-US/firefox/themes/ on FF31 (Win 7).
Closing bug.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.