[B2G][Helix][dialer][tongxiao]When the UE locked screen ,the incoming-call interface is wrong.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Dialer
P2
normal
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: lecky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; MALC; aff-kingsoft-ciba; .NET4.0C; .NET4.0E; Tablet PC 2.0)

Steps to reproduce:

【Detail Description*】: When the UE locked screen ,the incoming-call interface is wrong.
【Repro Steps*】:
1.The UE lock the screen.
2.make a call to the UE.
3.The UE put the incoming-call interface to the backstage.
4.then unlock the screen.
5.open the incoming-call interface and check the interface.
【Expect Result*】:the incoming-call interface is normal.
【Real Result*】:the incoming-call interface is only the bottom half of the interface.
【Test Count*】:10
【Found Count*】:10
【Gaia commit ID*】:c0ea0a4943dc8d3751b07f5b5c5d3abe06364a14 
【Gecko commit ID*】: 170f9e477571127cd40997fa2abe262ed43f0e4d
【Log*】:
【Network environment】:
【Resume operation】:
【Carrier】:
(Reporter)

Comment 1

4 years ago
Created attachment 8339712 [details]
20131128110518761.png
(Reporter)

Comment 2

4 years ago
There is another Repro Steps:
【Repro Steps*】:
1.The UE lock the screen.
2.the test phone make a call to the UE. After 5 or 6 seconds (the incoming-call interface do not appear in the UE),
  unlock the screen
3.when the incoming-call interface appear,check the interface.
【Expect Result*】:the incoming-call interface is normal.
【Real Result*】:the incoming-call interface is only the bottom half of the interface.
Flags: needinfo?(wchang)
(Reporter)

Updated

4 years ago
Priority: -- → P2

Updated

4 years ago
Flags: needinfo?(wchang)
Luke, do you have time to check this?
Flags: needinfo?(lchang)

Comment 4

4 years ago
Yes, I will take a look.
Flags: needinfo?(lchang)

Comment 5

4 years ago
Created attachment 8342830 [details] [diff] [review]
Bug-944227.patch

Per offline discussion, we both think that users don't need to hide the attention screen (the oncall page in this case) when their phone is locked. So this patch is trying to disable the functionality of home button when there is an incoming-call at lockscreen.
Assignee: nobody → lchang
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 6

4 years ago
Dear,
   I have tested the patch.
   【Repro Steps 1*】:
     1.The UE lock the screen.
    2.make a call to the UE.
    3.The UE put the incoming-call interface to the backstage.
    4.then unlock the screen.
    5.open the incoming-call interface and check the interface.
   The problem have been solved in Repro Steps 1.But there is still in the Repro Steps 2 of the comment 2:
    【Repro Steps 2 *】:
      1.The UE lock the screen.
     2.the test phone make a call to the UE. After 5 or 6 seconds (the incoming-call interface do not appear in the UE),
      unlock the screen
     3.when the incoming-call interface appear,check the interface.
(Reporter)

Comment 7

4 years ago
Dear,
   【Repro Steps 1*】:
     1.The UE lock the screen.
    2.make a call to the UE.
    3.The UE put the incoming-call interface to the backstage.
    4.then unlock the screen.
    5.open the incoming-call interface and check the interface.
 
   When I use the patch , there is still a problem : I answer a incoming-call in the unlocked_screen.
                                                     when I am  lock the screen ,the callscreen could not be switch to the background.
Thanks!

Comment 8

4 years ago
Created attachment 8343615 [details] [diff] [review]
Bug-944227-v2.patch

Due to offline discussion, I changed my workaround solution. Please remove the previous patch and apply this.
Attachment #8342830 - Attachment is obsolete: true

Updated

4 years ago
Assignee: lchang → nobody

Updated

4 years ago
Status: ASSIGNED → NEW
Hi guys! This issue does not reproduce in 2.2 (Gecko-c44a46f.Gaia-cdba6ca) so I am evolving the bug to RESOLVED - WORKSFORME. Please, do not hesitate to reopen it if the issue reproduces in some other version we should take care of. Thank you very much!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.