[Fugu] [B2G] emergencyCallsOnly is false even there is no sim card inserted

RESOLVED FIXED in 1.3 Sprint 6 - 12/6

Status

Firefox OS
RIL
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

unspecified
1.3 Sprint 6 - 12/6
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:fugu+)

Details

(Whiteboard: [Fugu] [v1.2f-uplift-needed])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
|mozMobileConnection[x].voice.emergencyCallsOnly| should be true when voice is not registered to network. But in fugu, even there is no sim card inserted, the emergencyCallsOnly is still false.
(Assignee)

Comment 1

5 years ago
After checking the code, the root cause is |ro.moz.ril.emergency_by_default| does not be set correct in fugu build. After set |ro.moz.ril.emergency_by_default| to true, the |emergencyCallsOnly| attribute is updated as we expected. However, the |ro.moz.ril.emergency_by_default| is for Akami [2][3], I think we could remove this RILQUIRK constant[1] since we are no longer supporting Akami any more.

[1] http://dxr.mozilla.org/mozilla-central/source/dom/system/gonk/ril_worker.js?from=ril_worker.js#82
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=714973#c8
[3] https://bugzilla.mozilla.org/show_bug.cgi?id=714973#c10
(Assignee)

Comment 2

5 years ago
Created attachment 8339841 [details] [diff] [review]
Patch, v1
(Assignee)

Updated

5 years ago
Attachment #8339841 - Flags: review?(htsai)
Comment on attachment 8339841 [details] [diff] [review]
Patch, v1

Review of attachment 8339841 [details] [diff] [review]:
-----------------------------------------------------------------

Thank you, thank you.
Attachment #8339841 - Flags: review?(htsai) → review+
(Assignee)

Updated

5 years ago
blocking-b2g: --- → 1.3?
Target Milestone: --- → 1.3 Sprint 6 - 12/6

Updated

5 years ago
blocking-b2g: 1.3? → fugu+
https://hg.mozilla.org/mozilla-central/rev/0a38dc2f9f29
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [Fugu] [v1.2f-uplift-needed]
(Assignee)

Updated

5 years ago
Blocks: 943227
You need to log in before you can comment on or make changes to this bug.