crash in libGLESv2_POWERVR_SGX540_120.so@0x4fe56

RESOLVED WORKSFORME

Status

()

Core
Graphics
P5
critical
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: gkw, Assigned: jgilbert)

Tracking

(4 keywords)

unspecified
All
Android
crash, reproducible, stackwanted, testcase-wanted
Points:
---

Firefox Tracking Flags

(firefox26- wontfix, firefox27- wontfix, firefox28- wontfix, fennec+)

Details

(Whiteboard: [native-crash], crash signature, URL)

(Reporter)

Description

4 years ago
This bug was filed from the Socorro interface and is 
report bp-493f3053-24ff-4c07-918e-5bd3f2131128.
=============================================================

Go to http://acko.net/blog/on-asmjs/ using Firefox 26 beta (the latest one as of today/yesterday), and you'll get an instant crash.

I'm using a Galaxy Nexus.
(Reporter)

Comment 1

4 years ago
Another report: bp-d9b508af-c5f7-4ecc-a79c-071052131127
(Reporter)

Comment 2

4 years ago
I'm on Galaxy Nexus 4.3, kernel version 3.0.72-gfb3c9ac, build number JWR66Y.
(Reporter)

Comment 3

4 years ago
I updated Firefox Nightly and it crashed too:

bp-03a51241-1f23-41ab-b8f0-dd6052131128
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox27: --- → ?
tracking-firefox28: --- → ?

Updated

4 years ago
Keywords: stackwanted
Does this reproduce on other devices as well?  Are there any URLs in the crash reports that are from more widely used sites?
Flags: needinfo?(gary)
Flags: needinfo?(gary) → needinfo?(aaron.train)

Updated

4 years ago
Flags: needinfo?(aaron.train)

Updated

4 years ago
Flags: needinfo?(kbrosnan)
This is a graphics driver crash and will affect any device that contains a PowerVR chip. It seems to be rather low volume 17 crashes over the last seven days. This particular signature is Galaxy Nexus only. 

However each OEM can make minor changes to the driver or Android which can cause the offset to be different. The other common PowerVR devices are the Samsung Tab 2.0 seven and ten inch models.
Flags: needinfo?(kbrosnan)
(Reporter)

Comment 6

4 years ago
> This is a graphics driver crash

Jeff mentioned to me in-person that even if the graphics driver is bad, we shouldn't propagate the crashiness out to Firefox (or something like that), so we can still probably fix this somehow.
Flags: needinfo?(jgilbert)
In that case we don't need to track this low volume crash for release blocking but can look at an uplift nomination to branches when a fix is verified.
tracking-firefox26: ? → -
tracking-firefox27: ? → -
tracking-firefox28: ? → -
(Assignee)

Comment 8

4 years ago
Yep, we should try to figure out what we're tickling in the driver to cause this crash, then work around it for this driver.
Flags: needinfo?(jgilbert)
Whiteboard: webgl-driver
(Assignee)

Comment 9

4 years ago
Oops, we don't actually know if this is a WebGL or layers issue yet.
Component: General → Graphics
Product: Firefox for Android → Core
Whiteboard: webgl-driver
tracking-fennec: --- → ?
Whiteboard: [native-crash]
Assignee: nobody → snorp
tracking-fennec: ? → 26+
I looked at this briefly. It appears to be crashing in WebGL during TexSubImage2D(). I don't know if it's a bounds issue or what.
Assignee: snorp → jgilbert
tracking-fennec: 26+ → +
filter on [mass-p5]
Priority: -- → P5
Closing this bug as there have been zero reports in over a year. Please reopen if this still reproduces for you in the latest Fennec.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox26: affected → wontfix
status-firefox27: affected → wontfix
status-firefox28: affected → wontfix
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.