Applying bold to para with first-letter style deletes text

VERIFIED DUPLICATE of bug 6059

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 6059
19 years ago
17 years ago

People

(Reporter: Simon Fraser, Assigned: buster)

Tracking

Trunk
All
Mac System 8.5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
In the editor, apply the 'Editor Styles 1' stylesheet. Select some text in the
middle of the paragraph which starts "Here is some very run-o-the-mill...", then
hit the bold button on the paragraph.

You loose all the text up to the character after the end of where the selection
was. This is pretty serious lossage.

Note that the stylesheet has p:first-letter styles.
(Assignee)

Comment 1

19 years ago
Simon: sorry, I don't have a current build or I'd test this myself.  Is this a
content manipulation problem or a display problem?  That is, do you really
"loose" the content (dump HTML and examine the output, is the text really
missing?) or is it just that the text isn't displayed after the change?  If it's
the first, assign this to Joe M10.  Otherwise, assign it to Kipp, and he'll
probably mark it a dup of a bug I sumbitted a long time ago.
(Reporter)

Updated

19 years ago
Assignee: buster → kipp
(Reporter)

Comment 2

19 years ago
This is a display problem; the content is still there; here is the HTML for that
para after the change:

<p>
Here is some very run<b>-o-the-mill text in a paragraph tag, for those
of you who are into that kind of thing. I think at this point I shall
regale you with some of my inestimable poetry, which will be presented
in blockquote mode for your reading pleasure.  This particular sample
was written when I was eleven years old, but is remarkably similar to
the w</b>ritings of my later &quot;hard-livin&quot; years.  It's titled &
quot;Reruns&quot;:
</p>

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 6059 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
verified in 7/9 build.
You need to log in before you can comment on or make changes to this bug.