[fugu] Unable to factory reset phone.

RESOLVED FIXED

Status

Firefox OS
Gaia::Settings
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Enpei, Unassigned)

Tracking

unspecified
x86_64
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:fugu+)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8340245 [details]
time stamp:15:04, 11/29.

Unable to reset phone.

* Build Number                
Gaia:     53bd0adc20e83ccf718c6d2c2a3905efb14d1bef
Gecko:    f239e6a56a72096ac4aff3d4cd8fcc01ac9471b5
BuildID   20131129093923
Version   28.0a1

* Reproduce Steps
Go to device information > More info > reset phone.

* Expected Result
Phone will run factory reset.

* Actual Result
No response.

* Occurrence rate
100%
(Reporter)

Comment 1

5 years ago
Hi Peipei,

I reproduce the bug on master build. Could you reproduce the bug on v1.2 as well?

Thank you.
Flags: needinfo?(pcheng)
Created attachment 8340895 [details]
fugu_v1.2_log.log

Reset phone did run factory reset on V1.2. However, after resetting, phone cannot start up.

BuildID:20131202105037
Version:26.0
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: e537f6f814ebd9aefc714e6743d7b4984ee6b16b
Flags: needinfo?(pcheng)
(Reporter)

Comment 3

5 years ago
Since v1.2 has reset phone function failed problem as well, use this bug for fugu issue tracking. Flag with fugu?.
blocking-b2g: --- → fugu?
Add Ying

Comment 5

5 years ago
Can you check whether there was librecovery.so in the phone with path system/lib?

The log indicated that there was no such file

11-29 15:01:52.400 I/Gecko   (  106): -*- RecoveryService: Unable to open librecovery.so



(In reply to pcheng from comment #2)
> Created attachment 8340895 [details]
> fugu_v1.2_log.log
> 
> Reset phone did run factory reset on V1.2. However, after resetting, phone
> cannot start up.
> 
> BuildID:20131202105037
> Version:26.0
> Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
> Gecko: e537f6f814ebd9aefc714e6743d7b4984ee6b16b

(In reply to Enpei from comment #1)
> Hi Peipei,
> 
> I reproduce the bug on master build. Could you reproduce the bug on v1.2 as
> well?
> 
> Thank you.

Comment 6

5 years ago
(In reply to pcheng from comment #2)
> Created attachment 8340895 [details]
> fugu_v1.2_log.log
> 
> Reset phone did run factory reset on V1.2. However, after resetting, phone
> cannot start up.

Please wait for more seconds.
Sometimes it may take one or two minutes .

> 
> BuildID:20131202105037
> Version:26.0
> Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
> Gecko: e537f6f814ebd9aefc714e6743d7b4984ee6b16b
(In reply to ying.xu from comment #5)
> Can you check whether there was librecovery.so in the phone with path
> system/lib?
> 
> The log indicated that there was no such file
> 
> 11-29 15:01:52.400 I/Gecko   (  106): -*- RecoveryService: Unable to open
> librecovery.so
> 
> 
> 
> (In reply to pcheng from comment #2)
> > Created attachment 8340895 [details]
> > fugu_v1.2_log.log
> > 
> > Reset phone did run factory reset on V1.2. However, after resetting, phone
> > cannot start up.
> > 
> > BuildID:20131202105037
> > Version:26.0
> > Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
> > Gecko: e537f6f814ebd9aefc714e6743d7b4984ee6b16b
> 
> (In reply to Enpei from comment #1)
> > Hi Peipei,
> > 
> > I reproduce the bug on master build. Could you reproduce the bug on v1.2 as
> > well?
> > 
> > Thank you.

I checked /system/lib. File librecovery.so does exist.
And I did wait for about 5 minutes. The device has a black screen after that, even manually start up.
Flags: needinfo?(ying.xu)

Updated

5 years ago
blocking-b2g: fugu? → fugu+

Updated

5 years ago
Whiteboard: [Fugu needs]

Comment 8

5 years ago
We have fixed the bug mentioned in the description.

But we haven't encountered the bug mentioned in comment 2.

peipei. Please check it with the latest build version. 

And you can change another phone and give a try.
Flags: needinfo?(pcheng)
(Reporter)

Comment 9

5 years ago
(In reply to ying.xu from comment #8)
> We have fixed the bug mentioned in the description.
> 
> But we haven't encountered the bug mentioned in comment 2.
> 
> peipei. Please check it with the latest build version. 
> 
> And you can change another phone and give a try.

Hi Ying.xu, could this fix be added to repository for DSDS v1.3? Function is still not working on 
Gaia      fbb6ce88ce8b7bd4d2efdb7a4a9f5a3c145f3eab
Gecko     a0bb585098cc89c454fac0297b5ef748d5cab82c
BuildID   20131210063021
Version   28.0a1

Thank you.
ying, please merge this patch to fugu git repo.
(In reply to ying.xu from comment #8)
> We have fixed the bug mentioned in the description.
> 
> But we haven't encountered the bug mentioned in comment 2.
> 
> peipei. Please check it with the latest build version. 
> 
> And you can change another phone and give a try.

I tested in today's build. But my phone is still unable to startup. I will double check using another phone.
Flags: needinfo?(pcheng)
Peipei, how do you build fugu, use mozilla github or sprd-ffos github.
I think ying need merge this patch to mozilla github fugu repo.
(In reply to James Zhang from comment #12)
> Peipei, how do you build fugu, use mozilla github or sprd-ffos github.
> I think ying need merge this patch to mozilla github fugu repo.

I get code directly from sprd-ffos github so the fix should have been included. but the build i compiled is engineering build. do you know if engineering build could affect this? 
Just tried in another phone, the same behavior appears(still unable to startup). so it is not device specific.

Updated

5 years ago
Whiteboard: [Fugu needs]
Enpei - Did you test this on a production build or an engineering build? To my understanding, factory reset only works on production builds, not engineering builds.
Flags: needinfo?(echu)
(Reporter)

Comment 15

5 years ago
(In reply to Jason Smith [:jsmith] from comment #14)
> Enpei - Did you test this on a production build or an engineering build? To
> my understanding, factory reset only works on production builds, not
> engineering builds.

Hi Jason, I tested Buri and Wasabi that both can do factory reset with engineering build, so I think supposedly it should work on Fugu as well.
Flags: needinfo?(echu)
(In reply to Enpei from comment #15)
> (In reply to Jason Smith [:jsmith] from comment #14)
> > Enpei - Did you test this on a production build or an engineering build? To
> > my understanding, factory reset only works on production builds, not
> > engineering builds.
> 
> Hi Jason, I tested Buri and Wasabi that both can do factory reset with
> engineering build, so I think supposedly it should work on Fugu as well.

That can't be right. Factory reset isn't a supported use case on any target engineering build.

See https://bugzilla.mozilla.org/show_bug.cgi?id=810457#c1.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 810457
I have add librecovery to device/sprd/sp7710ga_gonk/base.mk. Thomas, Can you get it?


diff --git a/sp7710ga_gonk/base.mk b/sp7710ga_gonk/base.mk
index 3420632..8113f71 100644
--- a/sp7710ga_gonk/base.mk
+++ b/sp7710ga_gonk/base.mk
@@ -15,6 +15,7 @@ PRODUCT_PROPERTY_OVERRIDES := \
 
 # original apps copied from generic_no_telephony.mk
 PRODUCT_PACKAGES := \
+       librecovery \
        DeskClock \
        Bluetooth \
        Calculator \
Flags: needinfo?(ttsai)
OK, I have updated device-sprd git repo on sprd-ffos github.

Comment 19

5 years ago
it has been fixed in v1.2f : device/sprd/sp7710ga_gonk.
 <project path="device/sprd" name="device-sprd" remote="sprd-github" revision="master" />
commit e10583051743f347bd8d7250bf64dfc5a354ac0e
Flags: needinfo?(ttsai)
Resolution: DUPLICATE → FIXED

Comment 20

5 years ago
clear the needinfo flag
Flags: needinfo?(ying.xu)
You need to log in before you can comment on or make changes to this bug.