save file truncates name

VERIFIED WORKSFORME

Status

()

Core
Networking: File
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: stef, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010807
BuildID:    2001080703

when saving files with a "dm-" prefix, they get stored with the file starting
only the dash, everything before the dash is ignored.

Reproducible: Always
Steps to Reproduce:
1. download a file over http named dm-*.zip
2. select save as.


Actual Results:  file is stored but with a filename which inhibits the "dm" part
before the dash.

Expected Results:  save it with a correct filename
wfm with win2k build 20010809..

The URL is dead (403) maybe referer problem.
I used:
http://www.mversen.de/dm-splash.zip
http://www.mversen.d2/dm-splash.zip (opened and then via save as)
This works for me on Linux 2001083108.  Reporter: can you download a newer build
and try again?
Marking WorksForMe since the reporter has not responded.

Reporter: if you still see this on a newer build from
http://ftp.mozilla.org/pub/mozilla/nightly/latest/ please re-open this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 5

17 years ago
VERIFIED:
+ testcase queue. I'll test for the next release, so it doesn't matter if we 
can't get reproter confirmation of WFM.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.