Closed Bug 944718 Opened 6 years ago Closed 6 years ago

[Cost Control] Broken access to usage widget from utility tray

Categories

(Firefox OS Graveyard :: Gaia::Cost Control, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:koi+, firefox26 fixed, b2g-v1.2 fixed, b2g-v1.3 fixed)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
firefox26 --- fixed
b2g-v1.2 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: sonmarce, Assigned: mai)

References

Details

(Keywords: regression)

Attachments

(3 files, 2 obsolete files)

Steps to reproduce:
1. Flash a device with today 1.2 build
2. Insert a SIM card
3. Boot the device
4. Go throw FTE
5. Open utility tray

Expected result: Get widget saying "New SIM card inserted" to start Cost Control FTE

Actual result: Get a broken widget (see screenshot)

It happens the same with no SIM card inserted
blocking-b2g: --- → koi?
Keywords: regression
I think you've got a bad build - this happens if you didn't flash the RIL correctly - check w/Isabel on this, since she hit this as well. I'll double check if this happens on our side just in case.

QA Wanted to double check if this reproduces generally.
Keywords: qawanted
I know there was a flash problem, but apparently this is another problem, we are investigating what is wrong
Assignee: nobody → mri
Doing some more tests, if no SIM card is inserted or no PIN entered, it always fail, but with SIM card inserted and entering PIN, it does not fail always.
Also, sometimes the problem does not appear after FTE, needing one or two reboots for the problem to happen
QA Contact: gbennett
I was unable to repro this issue on the build this was found, and the latest 1.2. Although I was able to repro this issue after taking the SIM out and looking at the notification dropdown. Let me know if that is relevant.

Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131129004001
Gaia: 395db5713ecc24398c607fe348978209f822146c
Gecko: edd1f3e93080
Version: 26.0
Firmware Version: 20131115

Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131129004001
Gaia: 395db5713ecc24398c607fe348978209f822146c
Gecko: edd1f3e93080
Version: 26.0
Firmware Version: 20131115
Keywords: qawanted
Marce - Is the issue found in comment 5 what you are seeing?
Flags: needinfo?(marce)
Duplicate of this bug: 944714
Sounds like salva answered the needinfo request per the dupe setting.

QA Wanted - does this reproduce on 1.1? Use the dupe's STR to reproduce this.
Flags: needinfo?(marce)
Keywords: qawanted
We have found the root cause of this. It is due a bad order of initializing components. We can provide a patch for tomorrow.
This does not reproduce on 1.1 using the dupe's STR as the no SIM warning is shown properly instead of what is seen in the attached image.

Environmental Variables:
Device: Leo 1.1 mozRIL
BuildID: 20131202041200
Gaia: 19c9ff3a46a4389e40253c97b359763243af4531
Gecko: 617eb9d9bcc2
Version: 18.0
Firmware Version: V10d
Keywords: qawanted
.:First Broken Build:.
Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131201004001
Gaia: 075e60c878b0eca68fba9e00bc85cb6eac03578a
Gecko: 14868788d50e
Version: 26.0
Firmware Version: 20131115

.:Last Working Build:.
Environmental Variables:
Device: Buri 1.2 mozRIL
BuildID: 20131113004000
Gaia: 20e8d407dac3bb2ad2616e8c2d8678d70fd82fa0
Gecko: 3fc449c858e6
Version: 26.0
Firmware Version: 20131115

I used a mozRIL for 11/30's build as there was no com for that day.
Someone put the spot of the 11/30 build in our share as the 11/13. I'll redo the regression window. Sorry about any confusion guys.
.:Last Working Build:.
Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131120004000
Gaia: 5ec2963fff60492c840707df8d8090f9908a5251
Gecko: 2d454e0de2ed
Version: 26.0
Firmware Version: 20131115

.:First Broken Build:.
Environmental Variables:
Device: Buri 1.2 comRIL
BuildID: 20131121004002
Gaia: ce276842c9ac1746073271fb736dfdb626a89240
Gecko: 36c4c667b9f2
Version: 26.0
Firmware Version: 20131115
This is affecting master as well.
Attached file proposal patch v1 (obsolete) —
Please, could you review the code?
Attachment #8341665 - Flags: review?(salva)
Duplicate of this bug: 946014
Comment on attachment 8341665 [details]
proposal patch v1

Now working perfectly. Thank you :mai!

Don't forget to add me as reviewer when merging and mark this bug as resolved including the commit hash in master.
Attachment #8341665 - Flags: review?(salva) → review+
Master: 439533ca95f598e34fd4fcd5ee1da1c7b45d5d91
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocking+ for critical regression
blocking-b2g: koi? → koi+
Pending patch for 1.2, this patch have code for DSDS that it's unnecessary for 1.2
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attached file patch for branch 1.2
Please, could you review the patch?
Attachment #8342973 - Flags: review?
Attachment #8342973 - Flags: review? → review?(jmcf)
Attachment #8342973 - Flags: review?(jmcf) → review+
v1.2: 65c0475608b25b56abedff8c21a9f1e5d718626c
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
backed out from master

https://github.com/mozilla-b2g/gaia/commit/50c75716ce9740ac1443e02140ae85b4885d47c5
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
it has been backed out due to regressions reported by bug 944718
this patch is not the only one responsible for 944718 regressions, thus relanding it

https://github.com/mozilla-b2g/gaia/commit/31bbe151e0d92da77a86a3ae5edb6ca2643968e1
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
I was not able to uplift this bug to v1.2.  If this bug has dependencies which are not marked in this bug, please comment on this bug.  If this bug depends on patches that aren't approved for v1.2, we need to re-evaluate the approval.  Otherwise, if this is just a merge conflict, you might be able to resolve it with:

  git checkout v1.2
  git cherry-pick -x  31bbe151e0d92da77a86a3ae5edb6ca2643968e1
  <RESOLVE MERGE CONFLICTS>
  git commit
Flags: needinfo?(mri)
I'm afraid I did already merge the patch on v1.2 branch. I didn't know I shouldn't do this. It will not happen again.

Regards
Flags: needinfo?(mri)
Hi, no problem in this bug. The patch for v1.2 version was landed in comment c22. Next time, Marina, wait for John ask for help or inform him about taking actions. No problem with providing a dedicated patch. x)

In addition, what JM reverted and landed again was in master and, as it was re-landed again, there is no more problems with this bug.
tester in:

12/09
master
Gecko c63c0a6
Gaia 1abda08

12/09
koi
Gecko 18c6a00
Gaia f615ae7
Status: RESOLVED → VERIFIED
Attached file pr14496.html (obsolete) —
For Jason recommendation I need to back out this patch for master version but the tree is closed at the present moment. Anyway I'm providing the proper patch for reviewing.

Once we backed out the bug and re-land it properly, it will solve regression described in bug 945469 as well.
Attachment #8341665 - Attachment is obsolete: true
Attachment #8344558 - Flags: review?(mri)
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
Attached file patch v2.0
Please, could your review the new patch
Attachment #8344558 - Attachment is obsolete: true
Attachment #8344558 - Flags: review?(mri)
Attachment #8344619 - Flags: review?(salva)
Comment on attachment 8344619 [details]
patch v2.0

This can not be applied cleanly on master, can you rebase it? Ask for review again then.
Attachment #8344619 - Flags: review?(salva) → review-
Depends on: 945469
master backout (redux): 24823a14069fee495b34d693d79bcf02a1da8764
Comment on attachment 8344619 [details]
patch v2.0

Ups, I forgot to give you the r+

Thank you!
Attachment #8344619 - Flags: review- → review+
Master: 3452fbdb5e1bed0cd27cc6173136537a03e8072f
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → FIXED
Please John, uplift this one **for 1.3 only** as the specific patch for 1.2 is already landed is it can be seen in comment 22.

Thank you all.
Flags: needinfo?(jhford)
[v1.3 c606310] Merge pull request #14501 from gitmai/bug-944718-Broken-usage-widget
Flags: needinfo?(jhford)
You need to log in before you can comment on or make changes to this bug.