Closed Bug 944782 Opened 8 years ago Closed 7 years ago

weather.com sends desktop content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: karlcow, Assigned: karlcow)

References

()

Details

(Whiteboard: [mobile-compat-form] [serversniff] [sitewait] [country-all])

Site: http://www.weather.com/
weather.com sends desktop content to Firefox OS

:: Steps To Reproduce

1. With firefox OS on ZTE
2. Go to http://www.weather.com/


:: Expected Result

Get the mobile content like Firefox Android

:: Actual Result

Received the Desktop Content.

:: Additional Information

Software Version: 1.1
Device Information: ZTE roamer2
Reporter's User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
to be contacted

# Firefox Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.weather.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Moved Temporarily
Accept-Ranges: bytes
Cache-Control: max-age=0, no-cache, no-store
Connection: keep-alive
Content-Length: 0
Date: Fri, 29 Nov 2013 18:31:25 GMT
Expires: Fri, 29 Nov 2013 18:31:25 GMT
Location: http://m.weather.com
Pragma: no-cache
Server: Varnish
X-Varnish: 165938820
dclass: mw4


# Firefox OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.weather.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Accept-Ranges: bytes
Cache-Control: max-age=0, no-cache, no-store
Connection: keep-alive
Content-Encoding: gzip
Content-Language: en-US
Content-Length: 25682
Content-Type: text/html;charset=UTF-8
Date: Fri, 29 Nov 2013 18:31:33 GMT
Expires: Fri, 29 Nov 2013 18:31:33 GMT
Pragma: no-cache
SVRNAME: wxii1x41
Server: Apache
Vary: Accept-Encoding
X-Cache-Hits: 60
X-Mod-Pagespeed: 1.2.24.1-2383
X-Varnish: 165941368 165940746
dclass: unknown
Assignee: nobody → kdubost
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [serversniff] [contactready] [country-all]
Assignee: kdubost → astevenson
Contacted developer via twitter.
Whiteboard: [mobile-compat-form] [serversniff] [contactready] [country-all] → [mobile-compat-form] [serversniff] [sitewait] [country-all]
No response.

Trying to contact via website form at http://feedback.weather.com
Received response looking for more detail.
Sending a follow up email.
Assignee: astevenson → nobody
Status: ASSIGNED → NEW
Whiteboard: [mobile-compat-form] [serversniff] [sitewait] [country-all] → [mobile-compat-form] [serversniff] [contactready] [country-all]
Adam,

any reasons why the bug is back to contactready? What was your last contact?
Sorry about that. My contact was from support, I provided all the details. A month later a follow up email but no response. Might be better to try another contact.
Vishal,

could you help us with this bug. Users of Firefox OS smartphones currently do not have access to the Mobile version of the site.

See above for comments.

FOSUA: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

Thanks.
Assignee: nobody → kdubost
Flags: needinfo?(vishal.shrivastava)
Status: NEW → ASSIGNED
See Also: → 1020983
Whiteboard: [mobile-compat-form] [serversniff] [contactready] [country-all] → [mobile-compat-form] [serversniff] [sitewait] [country-all]
OH!
This site is fixed. It proposes a pop up saying that we seem to have a mobile device. 
Then let us choose. 
It's working.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(vishal.shrivastava)
Resolution: --- → FIXED
Oddly all UAs and devices I test weather.com with now get something that looks like a desktop site.. No popup suggesting we switch to mobile either.
Yes, they're serving a Desktop to Chrome and Fennec as well now too.
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.