zip I/O error: No such file or directory on release builds after bug 926906

RESOLVED FIXED in Firefox 27

Status

defect
--
critical
RESOLVED FIXED
6 years ago
Last year

People

(Reporter: rail, Assigned: glandium)

Tracking

Trunk
mozilla28
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27 fixed, firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

+++ This bug was initially created as a clone of Bug #926906 +++

Copy from https://bugzilla.mozilla.org/show_bug.cgi?id=926906#c6

I think the change introduced in bug 926906 broke release builds. I was doing a staging beta release with the current aurora code and hit the following error on OSX (notice the target zip file name). We need to sort out this before 27.0b1 (12/9/2013).

cp -RL /builds/slave/rel-m-beta-osx64_bld-000000000/build/testing/profiles/prefs_general.js ./dist/test-package-stage/steeplechase
/builds/slave/rel-m-beta-osx64_bld-000000000/build/obj-firefox/i386/config/nsinstall -D ./dist/mac/en-US/
find ./dist/test-package-stage -name "*.pyc" -exec rm {} \;
cd ./dist/test-package-stage && \
	  zip -rq9D "/builds/slave/rel-m-beta-osx64_bld-000000000/build/obj-firefox/i386/dist/mac/en-US/Firefox /builds/slave/rel-m-beta-osx64_bld-000000000/build/obj-firefox/i386/27.0b1.tests.zip" \
	  * -x \*/.mkdir.done
zip I/O error: No such file or directory
zip error: Could not create output file (/builds/slave/rel-m-beta-osx64_bld-000000000/build/obj-firefox/i386/dist/mac/en-US/Firefox /builds/slave/rel-m-beta-osx64_bld-000000000/build/obj-firefox/i386/27.0b1.tests.zip)
make[3]: *** [package-tests] Error 15
make[2]: *** [postflight_all] Error 2
make[1]: *** [realbuild] Error 2
make: *** [build] Error 2
Summary: Drop support for GNU make < 3.81 → zip I/O error: No such file or directory on release builds after bug 926906
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
A staging release with this patch in progress. I'll update the patch with the results.

Thanks for the fast turn around!
Mac build passed! Waiting for others...
Linux 32/64 passed as well. I'll update whenever windows build is ready.
Windows passed too.
Blocks: 944903
No longer blocks: 943057
FTR, this needs to be landed on aurora before the merge day (12/9).
Attachment #8340559 - Flags: review?(mshal) → review+
Comment on attachment 8340559 [details] [diff] [review]
Fix test-package-step after bug 926906

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 926906
User impact if declined: Release build failure
Testing completed (on m-c, etc.): Tested on try by rail.
Risk to taking this patch (and alternatives if risky): Very low
String or IDL/UUID changes made by this patch: None
Attachment #8340559 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f047d2032ad7
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Attachment #8340559 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.