Closed Bug 944856 Opened 6 years ago Closed 2 years ago

[meta] Autocorrect is overzealous, and needs to be reigned in

Categories

(Firefox OS Graveyard :: Gaia::Keyboard, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: BenB, Unassigned)

References

Details

* Firefox OS
* Enabled "Autocorrect" in System preferences *1

*1 default on Geeksphone and Simulator, disabled in many actually sold phones

Reproduction:
1. Click into text field on webpage
2. Type "mt." using the virtual keyboard (not hardware keyboard)
3. Try to fix it.

Actual result:
* Autocorrected to "My."
* You can't fix it. It keeps getting auto"corrected".

Expected result:
"mt." stays

----------

This is a failure on many levels:
* Autocorrect shouldn't even be enabled on fields where it makes no sense.
* User should be able to override/disable autocomplete for specific words or textfields.
* Autocorrect should understand when I correct it and not persist, but learn.

I can't remember autocorrect going so wrong on any platform. This is because they have several of the above protections in place at the same time. We need to do the same.

This is a meta bug to attack the problem on several levels, not just one.
Depends on: 944857
In the case of "mt." (and any other auto-correction you don't like), hitting the backspace key will revert to what you typed.
That's good, I just tried and it works. But I didn't discover this myself.

It should "just work". My point here is that it must work out of the box, it must not get in the way, and to achieve that, we need solutions on several fronts.
Depends on: 944861
Depends on: 944862
No longer depends on: 943690
Depends on: 943690
Comment 0 is a great explanation of all autocorrect features that I've seen on any mobile device, FWIW.  :-)  They're never perfect.
When I try to send SMS-es with my device, I always have to tap on the 'x' button to have my typed words persist. When I press the space button, my typed word gets replaced by something I don't want, which is extremely annoying.
Hi Martijn, A list of words that are mis-suggested would be helpful.
Flags: needinfo?(martijn.martijn)
Jan, it's because I use the English version of FirefoxOS, the Dutch version was unusable for a while.
I'm now using the Dutch version again.
And I know how to turn off autocorrect, which was really undiscoverable (filed bug 1048341 for that).

But it still seems to me that tapping the "space" key should not autocorrect.
Flags: needinfo?(martijn.martijn)
(In reply to Martijn Wargers [:mwargers] (QA) from comment #6)
> But it still seems to me that tapping the "space" key should not autocorrect.

Actually, that seems to be the case now, in today's trunk build.
Ugh, never mind, I had autocorrect turned off.
> Comment 0 is a great explanation of all autocorrect features that I've seen on any mobile device,

Frankly, these are just the basics.
(Swype is a whole different order of complexity, maybe 100 times more complex. And extremely useful, so that iPhone users started to be jealous of my Android.)

What I described in comment 0 is really the absolutely bare minimum.
FYI, we have a Google Summer of Code intern working on self learning dictionary. But it doesn't look like it's gonna be finished though. So it's on our radar.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.