Macintosh Porting Bugs; many

VERIFIED INVALID

Status

SeaMonkey
General
VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: rkc, Assigned: asa)

Tracking

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla .9.3 has many minor incompatibilities on the macintosh that should be fixed:
Debug:XPToolkit
 * beep test makes no sound
Preferences
 * themes preferences page doesn't have enough space for all buttons
 * default screen resolution should be 72 dpi
System
 * application icon is missing
Conversion to Mozilla
 * when importing data, the address book info from netscape is not imported

Comment 1

17 years ago
> beep test makes no sound

True for beeptest, soundtest. Confirm but dup of Bug 64156, Bug 64155

> themes preferences page doesn't have enough space for all buttons

Dup 85226 , Bug 93866

> default screen resolution should be 72 dpi

The 72dpi of NS4.7x begin to be a major weakness on Mac, I don't think that it's
a great idea to set Moz to 72dpi...

> application icon is missing

Rebuild desktop.

> when importing data, the address book info from netscape is not imported

dup but I don't find the exact bug... 

Reporter: There should be only one bug per report. Plese refer to the bug
writing guidelines: http://www.mozilla.org/quality/bug-writing-guidelines.html

Bugzilla helper makes it easier to comply with the guidelines.
http://www.mozilla.org/quality/help/bug-form.html

> * beep test makes no sound

Bug 64156.

> * themes preferences page doesn't have enough space for all buttons

same as bug 85226?

> * default screen resolution should be 72 dpi

1) Defaulting to 72 ppi leads to trouble, because Windows-based authors think
that that 1 pt == 4/3 px everywhere.
2) For a long time, Apple has been shipping displays whose real physical
resolution exceeds 72ppi.

Please see http://www.hut.fi/u/hsivonen/units.html

> * application icon is missing

Worksforme. Have you tried rebuilding the desktop file?

> * when importing data, the address book info from netscape is not imported

Please file a bug with more detail in the Profile Migration component.
Resolving as INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 3

17 years ago
nc4 addressbook import requires a commercial product which we don't have, 
manually export using nc4 and then import that file w/ mozilla.

veri inva 1 bug per report (preferably not a duplicate) - thank you
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.