drawImage seems to draw random bits of memory when copying from <video>.

RESOLVED INCOMPLETE

Status

()

Core
Canvas: 2D
RESOLVED INCOMPLETE
5 years ago
2 years ago

People

(Reporter: benjamin, Unassigned, NeedInfo)

Tracking

24 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8340637 [details]
Two sightings of the bug, one on top of the other. It's supposed to be two frames from Big Buck Bunny.

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130824145019

Steps to reproduce:

I used drawImage to copy a frame of video from a <video> element and draw it in (on?) a canvas. At first I thought there was something off with my markup, but then I noticed the same problem with published examples online, such as one at <http://www.craftymind.com/factory/html5video/CanvasVideo.html>. At #introduction@irc.mozilla.org I was requested to file a bug report with the security checkbox ticked.


Actual results:

The canvas filled with the video frame as expected, up to a point. Then the rest of the image was filled with what looks like random pieces of unrelated content. Sometimes an image from another tab. Sometimes a garbled rendering of parts of another web page. Sometimes what looked like a tileset. Sometimes a grey fuzz, sometimes nothing but whiteness and lint... I'm doing a terrible job of explaining this. I'll attach an image with two typical cases to illustrate.


Expected results:

drawImage should have drawn the supplied image, in this case a frame from a <video>. It works as expected in Chromium 28.0.1500.71, for what it's worth.
I'm not seeing the bug with a more recent version (also on windows, not linux). Do you still see the problem in a build that's not so old?  http://nightly.mozilla.org

Updated

5 years ago
Flags: needinfo?(benjamin)
I tried this on Ubuntu 13.04 64 bit, FF20 26 and 28. I didn't see any redraw issues.

Also tried a handful of other configs (Win7, Mac) and no issues there either.

If you download a newer build, try it and tell us if it's still a problem for you.

Comment 3

5 years ago
Resolving as incomplete since it cannot be reproduced and no response from reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INCOMPLETE

Updated

3 years ago
Group: core-security → core-security-release
Group: core-security-release
You need to log in before you can comment on or make changes to this bug.