add-ons: when installing, download reports add-on corrupt

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Landis Reed, Unassigned)

Tracking

28 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131130030209

Steps to reproduce:

1: firefox > add-ons > search add-ons or got to addons.mozilla
2: Select almost any add-on > click: Add to Firefox 'button'
3: add-on starts download and install process
-or- 
4: Right-Click on add to ff button > save as > and try to install from Add-ons page as a file also fails.


Actual results:

1: dialog reports ' the addon downloaded from addons.mozilla.org could not be installed because it appears to be corrupt.

**View my Add-ons Collection page, 'Must Have'. Every Add-on on these 2 pages fail except for Web Developer and Session Manager... 
( https://addons.mozilla.org/en-US/firefox/collections/landistwo/favorites/ )



Expected results:

Add-on should either install or report not compatible with Firefox 28

Comment 1

4 years ago
WFM with 2013-11-30-03-02-09-mozilla-central-firefox-28.0a1.en-US.linux-x86_64.

Is it using a proxy?
I've recently tested the top 20 addons from AMO and I had no problem installing them.
Try on a new profile.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
Or there was a problem with addons.mozilla.org server.
You need to log in before you can comment on or make changes to this bug.