Page not displaying fully due to "HTTPS Everywhere" add-on

RESOLVED WORKSFORME

Status

()

Firefox
Extension Compatibility
RESOLVED WORKSFORME
4 years ago
a month ago

People

(Reporter: Harry Richards, Unassigned)

Tracking

25 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

Loaded page:
http://support.apple.com/downloads/#10.4.8%20combo.


Actual results:

The page loaded with part of it blank in the middle.


Expected results:

Extra content should have been displayed in the middle.

Comment 1

4 years ago
Cannot reproduce with Firefox 25.0 on Fedora 20.

Does the problem still happen if you start Firefox in Safe Mode? (Safe Mode disables extensions and themes, hardware acceleration and some JavaScript stuff in order to exclude some possible reasons for problems. It does not disable plugins which are add-ons.) See http://support.mozilla.com/en-US/kb/Safe+Mode 

And does this also happen with a new and empty profile? See http://support.mozilla.com/en-US/kb/Basic%20Troubleshooting#w_8-make-a-new-profile and http://support.mozilla.org/kb/Managing%20profiles
Flags: needinfo?(harrybugzilla)
(Reporter)

Comment 2

4 years ago
Found it's caused by the add-on, HTTPS-Everywhere:
https://www.eff.org/https-everywhere.
Flags: needinfo?(harrybugzilla)

Updated

4 years ago
Summary: page not displaying fully → Page not displaying fully due to "HTTPS Everywhere" add-on
Component: Untriaged → Extension Compatibility

Comment 3

4 years ago
I've been able to reproduce this bug and confirmed that it is fixed by disabling the Apple.com rule in HTTPS Everywhere. Please open a ruleset bug at https://github.com/EFForg/https-everywhere/issues.
Is this still an issue?
The only apple rule change i see is https://github.com/EFForg/https-everywhere/commit/b80007e4ea490a8d5d673fb816d124fd8a61e8f6#diff-6594837f75e34da15f18794199770151 since this report get filed.
Flags: needinfo?(harrybugzilla)

Updated

6 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → WORKSFORME
Flags: needinfo?(harrybugzilla)
You need to log in before you can comment on or make changes to this bug.