Unrequested <br> in every table cell

VERIFIED WONTFIX

Status

()

VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: hsivonen, Assigned: rubydoo123)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Build ID: 2001080105 FizzillaCFM

Reproducible: Always.

Steps to reproduce:
1) Create a new HTML document in Editor.
2) Click the "Table" button in the toolbar.
3) Click OK in the insertion dialog.
4) View HTML source.

Actual results:
Each table cell has a <br> in it. (They stay there after entering data in the
cells.)
Expected results:
Expected the cells to be empty. Expected to see no <br> unless I have explicitly
entered one by pressing shift-return.
Additional information:
I assume inserting the <br>s is a workaround for some text entry point issues.
However, a workaround that shows up in the source is rather ugly.
(Assignee)

Comment 1

17 years ago
the br is required for selection/text entry
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 2

17 years ago
v
Status: RESOLVED → VERIFIED
I know it is required for text entry. My point was that it would be better to
manage the entry point in some other way--in a way that doesn't leave traces in
the HTML source.

Comment 4

17 years ago
Dupe of bug 51318, which I just recommended be reopened on the grounds that
there is a bug filed to remove limitations in the caret code (bug 85505), which
when fixed should make this <br> hack unnecessary.
You need to log in before you can comment on or make changes to this bug.