Lock screen "Emergency calls only (no SIM)" not obvious

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: walter, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131201175730

Steps to reproduce:

Run ZTE Open without a SIM.


Actual results:

Lock screen shows tiny "Emergency calls only (no SIM)" in white.


Expected results:

Something more obvious would be nicer. Maybe bigger, in another colour, etc. Maybe a pulsating line drawing of a SIM card to save the i18n effort? :)

Note that this could be annoying if people have no plans to use GSM.

How do digital cameras do it when you fail to insert an SD card? They basically leave the screen on with an alert when they start up, but if you bypass it then they leave you alone.
Is this still an issue after so many visual refreshes? If it is, we may need NI UX to solve this.
Flags: needinfo?(walter)
Since this is a really old bug and no one replies me, close it.
If it's still a valid bug please re-open it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(walter)
You need to log in before you can comment on or make changes to this bug.