Closed Bug 945080 Opened 7 years ago Closed 7 years ago

"White dots" appears above and below the camera icon for 1.5dppx phones

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: timdream, Assigned: gweng)

References

Details

(Whiteboard: [FT:System-Platform])

Attachments

(1 file)

46 bytes, text/x-github-pull-request
timdream
: review+
Details | Review
+++ This bug was initially created as a clone of Bug #919410 +++

STR:

1. With lock screen enabled, look at the lock screen handle.

Expected:

1. The semi-transparent borders surrounds icons and handle perfectly. 

Actually:

1. "White dots" appears above and below the camera icon for 1.5dppx phones, caused by overlapping semi-transparent borders.

Greg, would you be able to deliver a quick fix on this? It might be better if we change the CSS rules to avoid problem like this. Talk to me in person if you need anything.

Blocking: Should block release because Andreas said lock screen has to be prefect.
Flags: needinfo?(gweng)
The border itself is not perfectly surrounds the blue handle if you drag it all the way left/right on a 1.5dppx phone either.

How about drawing the border with the <canvas> element itself? That *should* be prefect right? But I am not sure if using border-radius on canvas will trigger any sub-optimal rendering path on Gecko though.
Assignee: nobody → gweng
Attached file Patch
Re-implemented the way to draw the border with Canvas for this bug.
Attachment #8340977 - Flags: review?(timdream)
Flags: needinfo?(gweng)
Comment on attachment 8340977 [details] [review]
Patch

Thanks!
Attachment #8340977 - Flags: review?(timdream) → review+
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
--- since the bug has already made to v1.3.
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.