disable drmserver and installd

RESOLVED FIXED

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gal, Assigned: james.zhang)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3T fixed)

Details

(Whiteboard: [POVB])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
A chipset vendor requested that we disable starting drmserver and installd via build/core/user_tags.mk since we use neither. Ideally we shouldn't build and install them either.

Comment 1

5 years ago
Hi! Thomas,

Over to you. Thanks.

--
Keven
Assignee: nobody → ttsai

Updated

5 years ago
Blocks: 944457
No longer blocks: 944457
(Assignee)

Comment 2

5 years ago
Created attachment 8340957 [details] [diff] [review]
945136.patch

I have verified on fugu.
(Assignee)

Updated

5 years ago
Attachment #8340957 - Flags: review?(ttsai)

Comment 3

5 years ago
how about these 3 .so? They are still built and included in the rom.
	libfwdlockengine.so
	libdrm1_jni.so
	libdrm1.so

Updated

5 years ago
Attachment #8340957 - Flags: review?(ttsai)

Comment 4

5 years ago
any comment if all these DRM related are removed?
    drmserver.so
    libdrmframework.so
    libdrmframework_jni.so
libfwdlockengine.so
	libdrm1_jni.so
	libdrm1.so
Flags: needinfo?(mwu)
Flags: needinfo?(mchen)

Updated

5 years ago
Assignee: ttsai → dliang

Updated

5 years ago
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → ARM
(Assignee)

Comment 5

5 years ago
(In reply to thomas tsai from comment #3)
> how about these 3 .so? They are still built and included in the rom.
> 	libfwdlockengine.so
> 	libdrm1_jni.so
> 	libdrm1.so

Remove these 3 .so will cause build error.
(Reporter)

Comment 6

5 years ago
We can add a repo that exports dummy versions of those libraries. We did that for other Dalvik and Jni stuff too. Saved memory on disk and ram.

Comment 7

5 years ago
Currently /system/bin/drmserver is running on the system.
We need to remove it from init.rc too.
Flags: needinfo?(mchen)

Comment 8

5 years ago
(In reply to Andreas Gal :gal from comment #6)
> We can add a repo that exports dummy versions of those libraries. We did
> that for other Dalvik and Jni stuff too. Saved memory on disk and ram.

We need to find out the dependency and to see whether we can remove that dependency chain entirely.
Or maybe we can do fakedrmXXX to expose necessary APIs.
(Assignee)

Comment 9

5 years ago
(In reply to Marco Chen [:mchen] from comment #7)
> Currently /system/bin/drmserver is running on the system.
We need to remove
> it from init.rc too.

If drmserver hasn't been built, we need not remove it from init.rc.

Comment 10

5 years ago
In general *_jni.so libraries aren't necessary. I remember removing all of them, though.
Flags: needinfo?(mwu)
(Assignee)

Comment 11

5 years ago
(In reply to Michael Wu [:mwu] from comment #10)
> In general *_jni.so libraries aren't necessary. I remember removing all of
> them, though.

Please check B2G/out/target/product/<device>/installed-files.txt, you can find many *jni*.so.
(Assignee)

Updated

5 years ago
Flags: needinfo?(mwu)
(Assignee)

Comment 12

5 years ago
Michael, please remove all unnecessary jni so to shrink ROM size, it's very important to tarako device.
blocking-b2g: --- → 1.3?
(Assignee)

Updated

5 years ago
Flags: needinfo?(styang)

Updated

5 years ago
Blocks: 944457
Flags: needinfo?(styang)

Comment 13

5 years ago
(In reply to James Zhang from comment #12)
> Michael, please remove all unnecessary jni so to shrink ROM size, it's very
> important to tarako device.

Hi James,

May I know why shrink ROM size is important to tarako device too (not only RAM)?
Because these JNI libraries are only about 200k Bytes only.
(Assignee)

Comment 14

5 years ago
(In reply to Marco Chen [:mchen] [PTO from 2013/12/24 ~ 2014/01/02] from comment #13)
> (In reply to James Zhang from comment #12)
> > Michael, please remove all unnecessary jni so to shrink ROM size, it's very
> > important to tarako device.
> 
> Hi James,
> 
> May I know why shrink ROM size is important to tarako device too (not only
> RAM)?
> Because these JNI libraries are only about 200k Bytes only.

I have removed all unused JNI libraries on gonk side. We also need shrink ROM size to 100M for fastboot.
(Assignee)

Comment 15

5 years ago
Fixed on gonk side, please sync tarako code.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: tarako
(Assignee)

Updated

5 years ago
Assignee: dliang → james.zhang

Updated

5 years ago
Whiteboard: tarako → [tarako]

Comment 16

5 years ago
(In reply to James Zhang from comment #14)
> I have removed all unused JNI libraries on gonk side. We also need shrink
> ROM size to 100M for fastboot.

Could I know the detail of what there is a limitation of 100MB on fastboot?
If it is caused by memory then could we do traffic control?

(Thanks for your kindly response. I just want to make sure the reason of shrinking ROM size.)
(Assignee)

Comment 17

5 years ago
(In reply to Marco Chen [:mchen] [PTO from 2013/12/24 ~ 2014/01/02] from comment #16)
> (In reply to James Zhang from comment #14)
> > I have removed all unused JNI libraries on gonk side. We also need shrink
> > ROM size to 100M for fastboot.
> 
> Could I know the detail of what there is a limitation of 100MB on fastboot?
> If it is caused by memory then could we do traffic control?i
> 
> (Thanks for your kindly response. I just want to make sure the reason of
> shrinking ROM size.)

We use u-boot for fastboot,  it'll store the image in ram and the available memory is about 100MB.
What's the status here?  Does this still need to be a 1.3 blocker or have the fixes landed?
Flags: needinfo?(james.zhang)
(Assignee)

Comment 19

5 years ago
fixed on my side.
blocking-b2g: 1.3? → ---
Flags: needinfo?(james.zhang)
add [POVB] and 1.3T+ so it gets tracked for tarako
blocking-b2g: --- → 1.3T+
Whiteboard: [tarako] → [POVB]
status-b2g-v1.3T: --- → ?
Marking 1.3t fixed per comment 19
status-b2g-v1.3T: ? → fixed

Updated

5 years ago
Flags: needinfo?(mwu)
You need to log in before you can comment on or make changes to this bug.