Closed Bug 945140 Opened 8 years ago Closed 8 years ago

[DSDS] SIM 2 can still MT/MO SMS and MT voice call in airplane mode.

Categories

(Firefox OS Graveyard :: RIL, defect)

x86_64
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

VERIFIED FIXED
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: echu, Assigned: eragonj)

References

Details

(Whiteboard: [dsds_US_test])

Attachments

(4 files)

When device is in airplane mode, user can still send and receive SMS and receive incoming call through SIM 2.

* Build Number                
Gaia:     f64d282b6b44eaaf8cddc8be8f3250cb6fbacd95
Gecko:    0e3362fb5625eb6d98c7617b1b3019a2cc553d47
BuildID   20131202094818
Version   28.0a1

* Reproduce Steps
1. Enable airplane mode.
2. Send SMS to SIM 2.
3. Send SMS from SIM 2.
4. Dial call to SIM 2.

* Expected Result
Both SIM cards cannot MT/MO SMS and MT voice call in airplane mode.

* Actual Result
SIM 2 can still MT/MO SMS and MT voice call in airplane mode.

* Occurrence rate
100%
blocking-b2g: --- → 1.3?
Whiteboard: [dsds_US_test]
Assignee: nobody → arthur.chen
Blocks: 926342
Hi Sam,

I remember that per our previous discussion on email, I was told because fugu has only one modem, both rild will be turned off even we set radio off (REQUEST_RADIO_POWER) only for 1 rild. And both rild will receive notification of radio off. However, our test shows a different result. What we noticed is only the rild which requested radio off has being turned off. The other one is still power on. 

This is different from our previous discussion; thus I'd like to confirm the behaviour of modem with you again so that we have a better idea of the fix. Thank you.
Flags: needinfo?(sam.hua)
Seeing this also while working on bug 928297.
Hi Hsin,

Yes, I find the email,but I made the mistake. 

In DSDS, the REQUEST_RADIO_POWER doesn't mean to turn off the radio of the handset but turn off the radio function of the SIM card.
If we want to enter airplane mode, we should ask both radiointerfaces to send REQUEST_RADIO_POWER to modem.

I don't know how u design the user case that how to control the airplane mode when u turn off SIM1 or SIM2.
Flags: needinfo?(sam.hua)
Assignee: arthur.chen → ejchen
(In reply to sam.hua from comment #3)
> Hi Hsin,
> 
> Yes, I find the email,but I made the mistake. 
> 
> In DSDS, the REQUEST_RADIO_POWER doesn't mean to turn off the radio of the
> handset but turn off the radio function of the SIM card.
> If we want to enter airplane mode, we should ask both radiointerfaces to
> send REQUEST_RADIO_POWER to modem.
> 
> I don't know how u design the user case that how to control the airplane
> mode when u turn off SIM1 or SIM2.

Thanks for the confirmation, Sam.
Then we will correctly handle the case, i.e. asking both radiointerfaces to send REQUEST_RADIO_POWER as you suggested.
Attached file WIP
Hi Alive, 

after discussing with Arthur, we think it would be better to leave 'airplane' mode logic in system and maintain the code there only in order not to produce duplicate code. 

In Gaia side, all apps can just observe 'ril.radio.disabled' change to reflect its UI change. And system app is the only app that will monitor its change and call setRadioEnabled to communicate with Gecko. 

What do you think about this implementation :) ?
Attachment #8342987 - Flags: feedback?(alive)
Attached image flow.jpg
(draft) This is the flow in my mind, please take a look before looking patch.

Thanks :)
1. I tend not to overload IAC.
2. I do not have bandwidth this week so I propose to discuss this during team building with Arthur.
Duplicate of this bug: 947470
Comment on attachment 8342987 [details] [review]
WIP

f+ if not using IAC.
Attachment #8342987 - Flags: feedback?(alive) → feedback+
set to 1.3+ for this is blocking QC testing
blocking-b2g: 1.3? → 1.3+
Comment on attachment 8342987 [details] [review]
WIP

Arthur, 

what do you think about this implementation :) ?
Attachment #8342987 - Flags: feedback?(arthur.chen)
EJ,
Can we set a ETA to Dec/12?
This is highlighted by partner as blocking testing.
Flags: needinfo?(ejchen)
(In reply to Wesley Huang [:wesley_huang] from comment #12)
> EJ,
> Can we set a ETA to Dec/12?
> This is highlighted by partner as blocking testing.

Sorry for the late reply, Wesley. 

I just discussed this with Arthur & Alive in the afternoon, and we think we may need a new design for better implementation (I mean on engineering part).

With new design, I dont think I can make it before 12/12 (because the code needs to be reviewed, tested as well). But for my temporary patch, I think it would be possible to get done on 12/12. 

I will discuss with Arthur & Alive tomorrow to make sure whether we can postpone the new design as follow-up bug and implement it later. 

Thanks for your help, Wesley :)
Flags: needinfo?(ejchen)
Comment on attachment 8342987 [details] [review]
WIP

Hi Alive, 

I just discussed with Arthur that we may need a quick solution right now to meet the deadline because it is blocking partner testing and needed to be fixed soon.

I will open a follow-up bug to track AirplaneModeHelper if you don't mind (waiting for your response). 

Thanks !

Hi Arthur, xD.
Attachment #8342987 - Flags: review?(arthur.chen)
Attachment #8342987 - Flags: review?(alive)
Attachment #8342987 - Flags: feedback?(arthur.chen)
Comment on attachment 8342987 [details] [review]
WIP

r+ with nits
Attachment #8342987 - Flags: review?(alive) → review+
(In reply to Alive Kuo [:alive][NEEDINFO] from comment #15)
> Comment on attachment 8342987 [details] [review]
> WIP
> 
> r+ with nits

Thanks Alive.
Comment on attachment 8342987 [details] [review]
WIP

r=me. Thank you!
Attachment #8342987 - Flags: review?(arthur.chen) → review+
Attached file WIP2
Arthur, I am not sure why my last WIP not working anymore. 

In this way, I tried with another approach to make sure it work on Fugu. 

Can you take a look at it ? thanks :)
Attachment #8346988 - Flags: review?(arthur.chen)
Comment on attachment 8346988 [details] [review]
WIP2

Hi Alive, 

yesterday I found a bug related to Gecko part and refactored my code at the same time. 

It works well on Fugu with patched Gecko (you can check the dependency), and I think I need your re-review on system part.

Please give me a hand on reviewing this bug, thanks :)
Attachment #8346988 - Flags: review?(alive)
Comment on attachment 8346988 [details] [review]
WIP2

Please check my comments in github. Thanks!
Attachment #8346988 - Flags: review?(arthur.chen)
Comment on attachment 8346988 [details] [review]
WIP2

Looks like the change to 2 files are very similar so just do what arthur said.
Attachment #8346988 - Flags: review?(alive)
Comment on attachment 8346988 [details] [review]
WIP2

just addressed Arthur's comments and will bypass r? to Arthur only based on Alive's comments.

Sorry to bother your again, Arthur. 

Please help me review again and if they all look nice, I will rebase and force pushing again. Thanks.
Attachment #8346988 - Flags: review?(arthur.chen)
Comment on attachment 8346988 [details] [review]
WIP2

r=me. Thank you!
Attachment #8346988 - Flags: review?(arthur.chen) → review+
Thanks all for your great help! 

This patch was pushed onto : 

Gaia/master : f5454b4826b2c36ceb869c8c1f6a339be5db9749
Gaia/v1.3 : 1752e9e8f2b84b9db5d96ae5940596957fc8ed6c

:)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Please remember to set status flags accordingly when landing on a branch.
No longer blocks: 926342
See Also: → 926342
Verified on Fugu, passed.

Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.