can't edit profiles if account email is on multiple accounts

RESOLVED FIXED

Status

developer.mozilla.org
Profiles
--
minor
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: groovecoder, Assigned: jezdez, Mentored)

Tracking

Details

(Whiteboard: [easypickings][good first bug])

(Reporter)

Description

5 years ago
We receive bug reports when someone is unable to edit their profile because it has a duplicate email address to another profile. E.g., https://bugzilla.mozilla.org/show_bug.cgi?id=924758 and https://bugzilla.mozilla.org/show_bug.cgi?id=938319

The underlying error is a MultipleObjectsReturned error from User.objects.get():

https://errormill.mozilla.org/mdn/mdn/group/121218/

We should update the code to handle when a profile shares an email address.

1. Use the profile.user_id for the lookup in UserProfileEditForm.save()
2. (Optional) Show a warning to the user that they have a duplicate account?

Updated

5 years ago
Severity: normal → minor
(Reporter)

Updated

4 years ago
Duplicate of this bug: 982038
(Reporter)

Updated

4 years ago
Whiteboard: [mentor=groovecoder][easypickings]
Also this lead to page move being broken (if the user has the right) without any error message.
(Reporter)

Updated

4 years ago
Assignee: nobody → sayan.chowdhury2012
(Reporter)

Comment 3

4 years ago
Thanks for looking at this, sayan. Please needinfo? me here if you have questions.
Whiteboard: [mentor=groovecoder][easypickings] → [mentor=groovecoder][easypickings][good first bug]

Comment 4

4 years ago
Hi,

I checked for this error by trying to change my email id in the edit profile page, it takes me to a page that says "Permission Denied". Can you tell how can i reproduce this bug?
(Reporter)

Comment 5

4 years ago
That might be bug 906883. Which might be a more valuable bug to fix first. ;)
Mentor: lcrouch
Whiteboard: [mentor=groovecoder][easypickings][good first bug] → [easypickings][good first bug]
(Assignee)

Updated

4 years ago
Assignee: sayan.chowdhury2012 → jezdez
(Assignee)

Comment 6

4 years ago
This should have been fixed in the current production version of MDN since we've refactored the user profile form to not use the email address anymore to identify a user account.
(Assignee)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.