Manually triggered builds shouldn't start "Windows 2012 x64 PGO"

RESOLVED DUPLICATE of bug 1047166

Status

Release Engineering
General
RESOLVED DUPLICATE of bug 1047166
5 years ago
a year ago

People

(Reporter: jhopkins, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1961] )

(Reporter)

Description

5 years ago
There was a day-old "Windows 2012 x64 PGO" job showing in the buildapi pending list and on mozilla-inbound tbpl for revision aa4d8931ec0e

Whatever is triggering that build (self-serve?) should not do it as the builder does not exist in buildbot.


Relevant IRC scrollback:

jhopkins: "Windows 2012 x64 PGO" is pending since yesterday  https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=aa4d8931ec0e
[12:28pm] RyanVM|sheriffduty: jhopkins: must have been a manually-triggered pgo run
[12:29pm] RyanVM|sheriffduty: it's OK to cancel
[12:29pm] RyanVM|sheriffduty: jhopkins: buildbot isn't smart enough to realize that we haven't run those in ages
[12:29pm] RyanVM|sheriffduty: or self-serve
[12:29pm] RyanVM|sheriffduty: or whatever determines which platforms a manually-triggered job runs on
[12:30pm] jhopkins: RyanVM|sheriffduty: are you saying that builder should go away?
[12:32pm] RyanVM|sheriffduty: jhopkins: AFAIK, it's gone (hence the perma-pending)
[12:32pm] RyanVM|sheriffduty: jhopkins: self-serve is trying to trigger it and buildbot doesn't know what to do with it
See bug 857486 - self-serve determines what jobs amount to "trigger PGO" by looking for PGO jobs that have been triggered over the past two weeks, so since we're never going to go two weeks without manually triggering PGO on inbound, making it go away requires killing them from the db back at least two weeks. Which according to my reading of that bug, we didn't actually do for central, we just managed to go two weeks without a manual triggering.

Or we could just keep doing what we've been doing since... last spring? last winter? and manually cancel them when we notice them.
(Reporter)

Comment 2

5 years ago
mysql> select distinct(buildername) from buildrequests where buildername like '% mozilla-inbound pgo-build' and submitted_at > (UNIX_TIMESTAMP() - 14 * 24 * 3600);
+--------------------------------------------+
| buildername                                |
+--------------------------------------------+
| Linux mozilla-inbound pgo-build            |
| Linux x86-64 mozilla-inbound pgo-build     |
| WINNT 5.2 mozilla-inbound pgo-build        |
| WINNT 6.1 x86-64 mozilla-inbound pgo-build |
+--------------------------------------------+
4 rows in set (36.18 sec)

Updated

4 years ago
Whiteboard: [kanban:engops:https://mozilla.kanbanize.com/ctrl_board/6/1961]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1047166
(Assignee)

Updated

a year ago
Component: Tools → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.