Closed Bug 945364 Opened 6 years ago Closed 6 years ago

Firefox Metro Start / Onboarding Screen

Categories

(Marketing :: Copy, task)

All
Other
task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Due Date:

People

(Reporter: mmaslaney, Assigned: matej)

Details

Attachments

(1 file, 2 obsolete files)

>>Project/Request Title:
Firefox Metro Start / Onboarding Screen

>>Project Overview:
We would like user's with a "fresh profile" (first run experience) to be presented with a welcome message and a couple of handy tips to better their browsing experience.

>>Creative Specs & Deliverables:
Copy will be needed to make sure the "Welcome" message and the Tooltips share the brands voice.

Reference Bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=941284


>>Launch Date:
2013-12-09

>>Creative Due Date:
2013-12-05

>>Mozilla Goal:
Firefox Deskop

>>Points of Contact:
mmaslaney@mozilla.com
This is basically a first run experience, adding a little bit of delight and education, then moving out of the user's workflow.


Features:


• Firefox logo with welcome message (inline with the current desktop start page)

• Coach marks that with a rotating orange highlight (see "Pin" in the mock)

• Welcome message and coach marks will move out of the workflow when the user begins to navigate.
Hi Michael, 

Thanks for submitting your request. Unfortunately, this is too short notice and at this time we are all working on other projects. Hopefully we can find a more reasonable timeline to work within to help you get an improved onboarding screen. 

To help figure out what needs to be done and the amount of time it will take, I want to confirm that you need both improved copy and design work. Can you also provide a bit more information around what the final deliverables will be? 

Thanks,
Jennifer
Understand, completely. We would only need copy for the welcome message and the tool tips.
I would also suggest that the copy needs review to ensure consistency - whether it's different copy or not depends on whether it is felt it must be reworked or not.

The strings are the most important to get locked down this week, prior to the Aurora uplift (due to l10n impact). 

This is also a really important change for metro - without the improvements on this screen, the alternative is a sea of white 'blank-ness' which does no justice. This is a huge improvement and one that is seen as truly important for the first-run experience, especially given how different Windows 8 is to a classic experience (from an OS point of view, as well as a Firefox point of view).

Help in reviewing the copy as priority would be of the utmost appreciated.

Thanks, Karen
Assignee: jbalaco → Mnovak
Component: Design → Copy
I've assigned this over to Matej. He is going to try to get to it this week.
Status: NEW → ASSIGNED
Hi all,

There's actually a lot less here than I thought and mostly it's looking really good as is. I just have a few questions and some changes, mostly stylistic things.

Is any of this copy, or even the formatting, dictated by the OS? If not, here are a couple of capitalization changes I'd like to make:

Top sites

Different by design

Search or go to a website


At the top, "right-click" should have a hyphen.


Let's also remove the word "here" from the two tips:

Find your top sites here

And your bookmarks here


On those tips, we could make the text a little more exciting and fun (this is just an alt option, though I like what's there now as well):

Look, it's your bookmarks!

And your tabs, too!


Another option is to change "Different by design" to the three points from the website:

Proudly non-profit

Innovating for you

Fast, flexible, secure


I think we can dial all this up when we have new messaging for Australis, but for now, I think keeping it simple and in line with other messaging is the way to go.

Thanks!
FWIW, I really like 'Different by design' especially since it resonates to the whole look & feel of metro and how we have embraced it (while retaining much of the Firefox feel). I also just really like the 'sound' of that tag line over the others :)
(In reply to Karen Rudnitski [:kar] from comment #7)
> FWIW, I really like 'Different by design' especially since it resonates to
> the whole look & feel of metro and how we have embraced it (while retaining
> much of the Firefox feel). I also just really like the 'sound' of that tag
> line over the others :)

Perfect. Let's stick with that.
I love the idea of adding personality to the tool tips. Could we get a version that covers top sites, tabs, bookmarks, the menu and history (which will "bleed" off-screen for most users).

Thanks for the quick turnaround, Matej.
A work in progress, but closure to the actual experience.
(In reply to mmaslaney from comment #9)
> I love the idea of adding personality to the tool tips. Could we get a
> version that covers top sites, tabs, bookmarks, the menu and history (which
> will "bleed" off-screen for most users).

Will these always appear in the same order for a user? Will all users see all of them?

I wondering if they can read sequentially or if each one should be more standalone.
(In reply to mmaslaney from comment #10)
> Created attachment 8342081 [details]
> Windows8-i03-(StartPage)-freshprofile.png
> 
> A work in progress, but closure to the actual experience.

Looking good, but "right-click" is still missing the hyphen.
Always in the same order, with "History" bleeding off the screen for our lower dpi users.
I actually decided against putting these in sequence. I think it would be most beneficial to give a little explanation of what each one is or does:


[tabs]

Looking for your tabs? Just pull down or right-click


[top sites] 

Go to the sites you visit most


[bookmarks]

Find pages you've saved for later


[menu] 

Access more features and options


[history]

See where you've been on the Web
Updated copy; thank you Matej.
Attachment #8341203 - Attachment is obsolete: true
Attachment #8342081 - Attachment is obsolete: true
Looks great! Happy to help.
Thanks, Matej!

Michael, do you need anything else for this request? If not, please go ahead and resolve it.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.