Missing persona/theme background on findbar since FF25

RESOLVED DUPLICATE of bug 891786

Status

()

--
trivial
RESOLVED DUPLICATE of bug 891786
5 years ago
5 years ago

People

(Reporter: jaramat, Unassigned)

Tracking

25 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8341235 [details]
ff_findbar-24_vs_2526.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Problem:
Findbar is missing background image from active theme set in Firefox since version 25 stable update.

Steps to reproduce:
1. Install a persona/theme.
2. Open the findbar by Ctrl+F/F3/menu entry Find/quick find.

Expected results:
Findbar has the same background image as the rest of Firefox's toolbars.

Actual results:
Findbar ignores the persona, has a color from system's current theme instead (#DBEAF9 for Windows 7), which usually does not correspond with the rest of Firefox's toolbars' background.

Possible cause:
(As I am looking at the XUL code using DOM Inspector) Findbar has been moved from under #browser-bottombox (which itself has a style set to use persona) to .browserSidebarContainer under notificationbox, which does not have any background image declared.

Note:
This is just a visual bug, therefore marked as being of trivial severity. It irks me and a lot of other people though.

Also, on a slightly unrelated note, please consider moving "Highlight all", "Match case", and "Close Find bar" buttons back to the left. It makes literally no sense having this huge and ugly gap between them and the rest of the findbar controls. It only makes people go all the way to the right with their cursor (that is, if they aren't using Esc to close the bar). It isn't anything unfixable with a bit of a CSS code but some people may think about switching to another browser just because of this.

I considered categorizing this bug as "Toolbars and Customization" but decided against it since this  bug is only visual and has nothing to do with findbar's functionality.
(Reporter)

Updated

5 years ago
OS: Windows 7 → All
Hardware: x86_64 → All

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 891786
You need to log in before you can comment on or make changes to this bug.