DMD fails to compile due to string literal assignment

RESOLVED DUPLICATE of bug 945131

Status

()

Core
DMD
RESOLVED DUPLICATE of bug 945131
4 years ago
4 years ago

People

(Reporter: diego, Assigned: diego)

Tracking

Trunk
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
When DMD is enabled in B2G it fails with this error:

/local/mnt/workspace/dwilson/b2g_ics_1.3/gecko/memory/replace/dmd/DMD.cpp:718: error: invalid conversion from 'const char*' to 'char*'

This was introduced in bug 819839. ARM gcc 4.4 does not allow string literals to be assigned to a non-const string. Making the string const seems to fix it.
(Assignee)

Comment 1

4 years ago
Sadly, tbpl B2G builds disable DMD by default. Which is why it wasn't caught.
(Assignee)

Comment 2

4 years ago
Created attachment 8341266 [details] [diff] [review]
patch
Assignee: nobody → dwilson
Status: NEW → ASSIGNED
Attachment #8341266 - Flags: review?(n.nethercote)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945131
Attachment #8341266 - Flags: review?(n.nethercote)
You need to log in before you can comment on or make changes to this bug.