If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add better crash integration so we can fail tests when gecko crashes

RESOLVED FIXED

Status

Testing
JSMarionette
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: lightsofapollo, Assigned: gaye)

Tracking

(Depends on: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [runner])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Right now its entirely possible we just hang when the b2g process crashes... At minimum we should fail the test and dump a crashlog.
Duplicate of this bug: 975717
Whiteboard: [runner]
(Assignee)

Updated

3 years ago
Assignee: nobody → gaye
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla-b2g/marionette-js-runner/commit/3ce8c414a5bc324f17ecd0109fb01d02c4dd86f5 thing landed on master but still needs to be downstreamed to gaia

Comment 3

3 years ago
Created attachment 8568708 [details] [review]
[gaia-node-modules] gaye:marionette-js-runner-1.0.2 > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Created attachment 8570105 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia-node-modules/pull/97

gaia-node-modules bit
(Assignee)

Comment 5

3 years ago
Landed on gaia-node-modules master after testing in gaia https://github.com/mozilla-b2g/gaia-node-modules/commit/4164b1d6f3d74ab0eb901550857ab52e24752a5c
(Assignee)

Comment 6

3 years ago
Created attachment 8570111 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28273

This is the downstream to gaia part.
Attachment #8570111 - Flags: review?(jlal)
Attachment #8570111 - Flags: review?(eperelman)
(Assignee)

Comment 7

3 years ago
(And stuff now works with make test-perf)

Updated

3 years ago
Attachment #8570111 - Flags: review?(eperelman) → review+
(Reporter)

Comment 8

3 years ago
Comment on attachment 8570111 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/28273

The code looks fine here but seems like we have some issues:

 - completely dies on bb
 - pretty red on TC https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=11ae4d37cc3520bb774dab43e47d47de3cb2ca42

Looks like on bb the problem is the insanely old python version (This is in particular very strange) and on TC it looks like we stall out on specific test suites.
Attachment #8570111 - Flags: review?(jlal) → review-

Updated

3 years ago
Blocks: 1141793
(Assignee)

Updated

3 years ago
Depends on: 1143868
(Assignee)

Comment 9

3 years ago
Landed on gaia master https://github.com/mozilla-b2g/gaia/commit/679aae25d631a96050a9fadd4ff1fb8325913b4f
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.