[FTU] network selection - refresh button remains selected after user selects to refresh network list.

RESOLVED FIXED

Status

Firefox OS
Gaia::First Time Experience
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: maat, Assigned: Neeraj)

Tracking

({regression})

unspecified
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.3 fixed)

Details

(Whiteboard: [systemsfe])

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
network selection - refresh button remains selected after user selects to refresh network list.

**PATH**
in netwrok selection select the refresh CTA

**EXPECTED**
refresh CTA will change state during interaction to acknowledge tap then return to original state

before tap 01 network selection - refresh before.png 
during tap 02 network selection - refresh after.png 
after tap  01 network selection - refresh before.png 

**ACTUAL**
upon tap refresh CTA remains in ‘on tap’ state : during tap 02 network selection - refresh after.png 


BUILD
unagi-ICS.
user.
master.
Rel0.4.
Sprint12.
B-209.
Gecko-0e3362f.
Gaia-f64d282
(Reporter)

Comment 1

4 years ago
Created attachment 8341429 [details]
01 network selection - refresh before.png
(Reporter)

Comment 2

4 years ago
Created attachment 8341430 [details]
02 network selection - refresh after.png
(Reporter)

Updated

4 years ago
blocking-b2g: --- → koi?
This really needs to be confirmed on 1.2 first - the screenshots here are using the visual refresh from 1.3.

QA Wanted - Can this be reproduced on 1.1 or 1.2?
Keywords: qawanted

Updated

4 years ago
QA Contact: sparsons

Comment 4

4 years ago
This issue does not repro on Buri 1.2 Build ID: 20131203004002

Gaia   c8f14ad3950d59ba13d7639eff02d080060bb3ce
SourceStamp 244e98241b2c
BuildID 20131203004002
Version 26.0

Also, this issue does not repro on the Leo 1.1 Build ID: 20131202041200

Gaia   19c9ff3a46a4389e40253c97b359763243af4531
SourceStamp 617eb9d9bcc2
BuildID 20131202041200
Version 18.0
Keywords: qawanted
Can we double check if this reproduces on 1.3?
Keywords: qawanted

Comment 6

4 years ago
This issue reproduces on Buri 1.3 Build ID: 20131203040236. Every other time the refresh button is selected, the button remains highlighted. Scrolling up and down the network list will resolve the issue. 

Gaia   31808a29cfcffa584b6a88b4f1e515387f485a1b
SourceStamp 8648aa476eef
BuildID 20131203040236
Version 28.0a1
Keywords: qawanted

Updated

4 years ago
Keywords: regression, regressionwindow-wanted
Per comment 4 and comment 6 changing blocking-b2g flag from koi? to 1.3?
blocking-b2g: koi? → 1.3?
I think this might be a fallout from the 1.3 visual refresh work.

Comment 9

4 years ago
This issue started to occur on the Buri 1.2 Build ID: 20131019040204

Gaia   d0861c2913a57cb681ec4cd4d52d73cc0f479ac9
SourceStamp e25e62d174ed
BuildID 20131019040204
Version 27.0a1


Last working Buri 1.2 Build ID: 20131018040217 

Gaia   18c2ab4b7b2d4cacee90fb85e97354142b2fad4a
SourceStamp 855da6d8a327
BuildID 20131018040217
Version 27.0a1
Keywords: regressionwindow-wanted
(Assignee)

Comment 10

4 years ago
Created attachment 8342293 [details] [review]
Proposed patch for this bug.

Hi Francisco,

Here is the PR(https://github.com/mozilla-b2g/gaia/pull/14356) for this bug. Please review it and let me know if it works.

Regards,
Neeraj
Attachment #8342293 - Flags: review?(francisco.jordano)
Comment on attachment 8342293 [details] [review]
Proposed patch for this bug.

Hi!

Could you try to remove the !important clauses from the css?

Also could you rebase?

Thanks a lot!!
Attachment #8342293 - Flags: review?(francisco.jordano)
(Assignee)

Comment 12

4 years ago
Hello,

Thanks for your review :)

If we remove !important, this patch does not work. We have figured out that !important in below css from header.css is causing the issue :

line : 137
section[role="region"] > header:first-child menu[type="toolbar"] button:not(:disabled):active  {
  background-color: #dc6a0e !important;
}
line: 337
.skin-organic section[role="region"] > header:first-child menu[type="toolbar"] button:not(:disabled):active  {
  background-color: #aae1e9 !important;
}

If we remove !important from above css, our css also work without !important. But because above is shared css, it will impact other apps if we change it.

Expecting for ur reply :)
Flags: needinfo?(francisco.jordano)
Ok, just wanted to be sure if we could workaround the |!important| directive.

If there is no way, is not a big deal :)
Flags: needinfo?(francisco.jordano)
Comment on attachment 8342293 [details] [review]
Proposed patch for this bug.

r+ ,please merge when travis green :)
Attachment #8342293 - Flags: review+
Did the travis build fail?

https://github.com/mozilla-b2g/gaia/pull/14356
Assignee: nobody → neeraj_kumar
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(neeraj_kumar)

Comment 16

4 years ago
Is this under system front end team's radar?
Flags: needinfo?(cserran)

Updated

4 years ago
Whiteboard: [systemsfe]
This never got merged. Neeraj, can you update the PR so that we can get a new travis run?
I couldn't merge the original PR any more.
I merged a new one.
https://github.com/mozilla-b2g/gaia/commit/19997fb17584649e1e072b31637567a8add3d78b
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Thanks Neeraj for the patch!
Flags: needinfo?(neeraj_kumar)
Flags: needinfo?(cserran)
Uplifted 19997fb17584649e1e072b31637567a8add3d78b to:
v1.3: b88eaef05f9bc292407f68b0b7727adb3b4c858d
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.