Closed Bug 945597 Opened 8 years ago Closed 8 years ago

Phone starts side-ways if placed horizontally and boot

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(blocking-b2g:1.3+)

RESOLVED FIXED
blocking-b2g 1.3+

People

(Reporter: timdream, Assigned: alive)

References

Details

Attachments

(1 file)

STR:

1. Place the phone side-says on a desk
2. Reboot the phone
3. Wait until the lock screen show up

Expected:

1. Lock screen shown in portrait 

Actual:

1. Lock screen shown in landscape
2. Once you unlock the phone, the home screen will be in portrait
3. However, if one turn off the screen and turn on again, the lock screen will once shown in landscape.

Note:

We have dealt with similar thing in Gaia (bug 936253). Greg, Alive, could you quickly work together to verify if there isn't any more bugs in Gaia orientation handling?

Viral, does this have anything to do with orientation: default?

This bug is reproducible on Peak and Unagi.
Flags: needinfo?(vwang)
Flags: needinfo?(gweng)
Flags: needinfo?(alive)
Taken
Assignee: nobody → alive
Flags: needinfo?(alive)
Component: General → Gaia::System::Window Mgmt
The root cause is gecko doesn't give us the default orientation, but we could do this trick by lockOrientation on device booting to get the default orientation.
Attachment #8341545 - Flags: review?(timdream)
Alive and I discuss this issue for bug 934556.
Now OrientationObserver will enable in nsAppShell and start to notify the sensor changes if we have any.
So if there's no any app lock orientation, OrientationObserver will keep working.

The way in my expect to lock in default orientation could be mozLockOrientation.
by using manifest.webapp seems more complexity to me.
Flags: needinfo?(vwang)
Comment on attachment 8341545 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14296

We could do that for now.

Do you think it make sense to expose |screen.mozDefaultOrientation|? I thought we have that already.
Attachment #8341545 - Flags: review?(timdream) → review+
Flags: needinfo?(gweng)
No, we don't have the API yet.
https://github.com/mozilla-b2g/gaia/commit/e2006c90dbd5c65946a2239aada4b0695ff39290
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Sounds like a regression, so that makes this a clear blocker.
blocking-b2g: 1.3? → 1.3+
You need to log in before you can comment on or make changes to this bug.