[RFE] More transparent/obvious caching [don't change extensions of files in cache]

VERIFIED DUPLICATE of bug 90558

Status

()

Core
Networking: Cache
--
enhancement
VERIFIED DUPLICATE of bug 90558
17 years ago
15 years ago

People

(Reporter: Blake Ross, Assigned: gordon)

Tracking

Trunk
mozilla1.0.1
PowerPC
Mac System 9.x
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Netscape 6.1 Suggestion
 
Primary Browser: 	iex  5 Mac
Language: 		Spanish  
Component: 		Navigator
Suggestion Category: 	Improvements  
Issues Details: 
As a web developer I NEED access to the cache.
Call that robbery, inspiration, or just
sneakpeaking, but  I need having a look to certain
.js, .swf or whatever other non-easy-downloading
files.

That is the only reason why I kept Netscape 4 in
my Mac, while my pirmary browser is IE5 (in a
Mac), besides for cross-browser compatibility of
my pages, of course. But for simple user
navigating I used IE5 since N4 is, simply put, an
absolute standards breaker. It, anyhow, was the
only browser that let me access files in the
cache. IE has a closed cache inaccessible to a user.

Now, I'm dazzled by N6.1 and how good it has
become from an absolut sh#t as N4 was, but
unfortunately, it follows IE5 (Mac) trend as to
not showing the cache in a transparent manner.

N6.1 does not use filename extensions as .htm,
.gif or .swf in its cache, and thus, it is
virtually impossible for me to dig its cache to
look for the files I am interested in.

N6.1 seems to pretend to be the developer's
favourite browser, still, without transparent
caching it is not going to get that, at least it
is not going to be mine. Sadly I still need N4
then. Please, fix this for N6.11

Comment 1

17 years ago
Actually, this would be good for all platforms.  One use for this is, after
watching a streaming Quicktime (for one example) in NS 4.x, I can go to the
cache and find the .MOV file and copy it.  This lets me watch the movie or show
it to friends without downloading it again.  On Mozilla, this is impossible,
unless I can figure out from the timedate stamp and file size which file it is.

I'd suggest changing the description to "Preserve file extensions in cache" or
seomthing, and making the platform All/All.
(Assignee)

Comment 2

17 years ago
Aren't you really asking for a way to save any file?  Why don't we change the
RFE to that, rather than specify how the cache should be implemented?  We're
actually moving away from saving everything as a separate file (it's not very
efficient).  I think we should rephrase the RFE so we can still achieve the
functionality you want, regardless of how/whether documents are stored in the cache.

Comment 3

17 years ago
Gordon, I can't speak for Blake, though from reading his description, it sounds
like what you propose would be fine.  It would suit me, so long as I had a
(relatively) easy way to *find* and save the contents of any file that is in the
cache.
(Assignee)

Comment 4

17 years ago
It doesn't really matter whether the document is in the cache or not, or if
there even IS a cache.  What I imagine you want is something like "save this
page...and all documents it requires" (.js, .jpg, .gif, etc.).  Would that do?

Comment 5

17 years ago
I don't want to usurp Blake's bug here (sorry, Blake), but my example about
Quicktime movies is the most common use I have for this feature.  Would Mozilla
recognize the QT movie as a "required document" in such cases?  In the
registered version of Quicktime, under Browser Plugin settings, there's a
checkbox for "Save movies in disk cache".  I don't know how this interacts with
a browser to know whether what you suggest would work, Gordon.  All I know is,
with NS 4.x, after viewing the movie, I'd go to the cache folder, look at the
most recent files and find the one with the right size and file extension, and
I'd copy that.  Preferably, I'd like to have an equally easy way to get at the
file in Mozilla.
(Assignee)

Comment 6

17 years ago
I don't think you're usurping Blake's bug.  My suggestion to rephrase the
request was made in the hope it could encompass both your needs.  He stated that
he wanted to examinne files that happened to be in the cache that we not easy to
download.  I suggest we make them easier to download, rather than specify how
the cache should store them.  That gives users the functionality of getting
files they want, while leaving the cache free to store data in the most
efficient/performant way possible.

Blake?
(Reporter)

Comment 7

17 years ago
Well, I was just bringing over some user's 6.1 feedback; I'm afraid I can't
clarify :-)

But yeah, saving a page images and all is a much requested feature.

Comment 8

17 years ago
Gordon: in that case, sure.  It doesn't really matter to me how this is done, so
long as it doesn't require some convoluted method to access or acquire the
files.  And the more efficient the cache, the better.
(Assignee)

Updated

16 years ago
Target Milestone: --- → mozilla1.0

Comment 9

16 years ago
Try typing about:cache into the URL bar.  I would say that works even better
than snooping in the cache dir in NS4.

Comment 10

16 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 11

16 years ago
I have indexing software installed that indexes all words in known documents
(HTM as well). If I want to be able to search through browser cache, I need
cached pages to have extension HTM or HTML.

Extension of files in cache should be those of original files, i.e. mostly .htm
or .html. This will allow to Indexing software to search words in browser cache
and open cached documents.

Comment 12

16 years ago
*** Bug 133682 has been marked as a duplicate of this bug. ***
changing summary for easier finding
Summary: [RFE] More transparent/obvious caching → [RFE] More transparent/obvious caching [don't change extensions of files in cache]

Comment 14

16 years ago
Where is this bug headed?

We can now save complete documents, so that is a non-issue, or outside the scope
of this bug.  Keeping extensions for cached files is bug 91595.  Cache viewing
can already be used to view files in the cache.  Is there anything left to do here?

Comment 15

16 years ago
Yes.  To use my previous examples, if I go to a page that has an embedded
Quicktime movie, doing a Save Complete Page does not save the Quicktime movie. 
If I don't use the Pro version of Quicktime, I wouldn't be able to save the
movie at all.

Please note I'm using Quicktime as an example because it's easy to test.  This
could apply to any kind of file.

Comment 16

16 years ago
Try getting the page info (View -> Page Info), go to the media tab, select the
movie, and click "Save As."
Problem solved.

Comment 17

16 years ago
Burpmaster, try going to
http://www.apple.com/trailers/disney/lilo_and_stitch-6.html and see if you can
use Page Info to save the actual trailer.  I can't.  All I can do is save the
small Quicktime movie that displays "Click here to begin"

Comment 18

16 years ago
That is a rather odd case, and you can browse to about:cache to look in the cache.
But you'll see that they're making sure that movie never gets cached in the
first place.  There's probably nothing Mozilla can do to allow you to save that
movie.
*** Bug 91595 has been marked as a duplicate of this bug. ***
actually, this bug and the one I just duped to this are probably duplicates as well.

*** This bug has been marked as a duplicate of 90558 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 21

15 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.