[B2G][Helix][WIFI][meijinfang]Status bar show wifi connected when no network connected.

RESOLVED INVALID

Status

P2
major
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: lecky.wanglei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; .NET4.0C; .NET4.0E)

Steps to reproduce:

1.Turn on wifi on the test device.
2.Set an AP on the assisted device.
3.Connect the AP with test device.
4.Turn off the AP on the assisted device.


Actual results:

The AP not existed in the network list, but the status bar show wifi connected.


Expected results:

The AP not existed in the network list, there is no wifi icon in the status bar.
(Reporter)

Updated

5 years ago
Severity: normal → major
Component: WMF → Wifi
OS: All → Linux
Priority: -- → P2
Hardware: All → ARM
(Reporter)

Comment 1

5 years ago
This is a low probability problem, already has happened twice.
(Reporter)

Comment 2

5 years ago
I think WifiManage has received the msg "WifiManager:ondisconnect" in func receiveMessage, because the status of networklist is correct, only the status bar has not been synchronized.

In system\js\wifi.js, onstatuschange proc is as below:
    // when wifi status change, emit event to notify StatusBar/UpdateManager
    wifiManager.onstatuschange = function onWifiDisabled() {
      var evt = document.createEvent('CustomEvent');
      evt.initCustomEvent('wifi-statuschange',
        /* canBubble */ true, /* cancelable */ false, null);
      window.dispatchEvent(evt);
    };

I think maybe this func has not been called, or the event has not been catched by statusbar.js.

Please help to analyze,
Thanks.
(Reporter)

Comment 3

5 years ago
Created attachment 8342815 [details]
20131203164449202.png
Hi Vincent,
can you or someone check this?
Flags: needinfo?(vchang)
I am trying to reproduce this with today's gecko and gaia. But I can't reproduce the problem described here. Can I have the version information ? 
gaia - b1e8a248862f85222446d0b634efc064f8a6ee68
gecko - changeset 159038:1401e4b394ad
Flags: needinfo?(vchang)
(Reporter)

Comment 6

5 years ago
The version is V1.1 hd, detail is as below:
gaia:ca94f480808a6a9d6cbb9116833a40f67ca55422
gecko:6922cdcfa9606b399d0fc195550fd76c819ad500

It's a low probability problem.
Thanks for your information, I'll try to check it soon.
I follow the STR ten times. But I still can't reproduce the problem. The device is Helix on v1.1 hd. 

gaia: commit 2d79d8c461262b4d819fba17a0e8cbc03b36b6b1
gecko: commit 1454b3d349ffa381709cf281986e55d8e9da5a49
(Reporter)

Comment 9

5 years ago
OK! For it's  a low probability issue, we will close the bug.
Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.