CalDAV: Error doing webdav sync: 403

RESOLVED DUPLICATE of bug 930132

Status

Calendar
Provider: CalDAV
RESOLVED DUPLICATE of bug 930132
4 years ago
4 years ago

People

(Reporter: Nico, Unassigned)

Tracking

Lightning 2.6.3

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131025151332

Steps to reproduce:

Using
- Thunderbird 21.1.1
- Lightning 2.6.3
- severals CALDAV remote calendar (Sogo Connector 24.0.2 module) stored on a owncloud server (v5.0)

I just tried to add an event


Actual results:

When I add an simple event :
- It works (the event is displayed in my selected calendar)
- But the yellow triangle appear near my selected calendar (calendar momentarily not available)
- If I add another event or modify an existing event, it doesn't work > But the yellow triangle disappear > So I can add another event > Then the yellow triangle appear again....

Consol error messages (sorry, some are in french) :
[JavaScript Warning: "CalDAV: Error doing webdav sync: 403"]

[JavaScript Warning: "Une erreur est survenue lors de la lecture de données de l'agenda : Professionnel. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : DAV_REPORT_ERROR. Description : Une erreur est survenue lors de la lecture de données de l'agenda : http://<MY SERVER>/remote.php/caldav/calendars/<USERNAME>/professionnel. Celui-ci a été désactivé jusqu'à ce que son utilisation soit sûre."]

[JavaScript Warning: "Une erreur est survenue lors de la lecture de données de l'agenda : Professionnel. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : READ_FAILED. Description : "]


Expected results:

Everything was working with lightning previous version (2.6.2)
(Reporter)

Updated

4 years ago
Component: Lightning Only → Provider: CalDAV

Comment 1

4 years ago
I confirm this, also using Lightning 2.6.3 connecting to an ownCloud 5.0.13 instance with the built-in CalDAV capabilities.

Here are the JavaScript warnings in English (with domain and user names obfuscated).

[JavaScript Warning: "There has been an error reading data for calendar: foobar.  However, this error is believed to be minor, so the program will attempt to continue. Error code: DAV_REPORT_ERROR. Description: There has been an error reading data for calendar: https://foo/remote.php/caldav/calendars/bar/defaultcalendar. It has been disabled until it is safe to use it."]

[JavaScript Warning: "There has been an error reading data for calendar: foobar.  However, this error is believed to be minor, so the program will attempt to continue. Error code: READ_FAILED. Description: "]
Status: UNCONFIRMED → NEW
Ever confirmed: true
could you enable calendar.debug.log and calendar.debug.log.verbose, restart and check the error console? I suspect this will be fixed by one of the bugs linked in bug 946202.
(Reporter)

Comment 3

4 years ago
I tried but when I select the error console ( Tools > error console ), Thunderbird is freezing.
I tried several times, but with same result (50% CPU, then I have to kill the process)

Comment 4

4 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #2)
I had the same errors as Nico some days ago (ownCloud 5.0.13, Lightning 2.6.3, no Sogo). The followup patch from Bug 930132 fixed them, so yes, Lightning 2.6.4 should probably help here.

Comment 5

4 years ago
I also see the hang opening Error Console with those calendar.debug.log options enabled. Phillipp, would that bug belong on Lightning Only or Thunderbird?

Comment 6

4 years ago
Same problem here. 
Server: Zimbra OSE 8.05.
Tbird: v24.2.0
Lightning: v2.6.3

Tried reinstalling thunderbird, also tried older versions.
The problem started to occur about 2-3 weeks ago.

Unfortunetly the debug log is hungarian:
CalDAV: itemUri.spec = https://mail.pcvilag.hu/dav/xxx%40xxxxxx.hu/Calendar/1153cd64-6030-4fdc-b690-86b8e7eb2460.ics
CalDAV: send: BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Budapest
X-LIC-LOCATION:Europe/Budapest
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20131211T210850Z
LAST-MODIFIED:20131211T210850Z
DTSTAMP:20131211T210850Z
UID:1153cd64-6030-4fdc-b690-86b8e7eb2460
SUMMARY:Új esemény
DTSTART;TZID=Europe/Budapest:20131214T114500
DTEND;TZID=Europe/Budapest:20131214T134500
END:VEVENT
END:VCALENDAR

CalDAV: recv: 

CalDAV: Item added to Balu successfully

CalDAV: send(https://mail.pcvilag.hu/dav/xxx%40xxxxxx.hu/Calendar/): <?xml version="1.0" encoding="UTF-8"?>
<C:calendar-multiget xmlns:D="DAV:" xmlns:C="urn:ietf:params:xml:ns:caldav"><D:prop><D:getetag/><C:calendar-data/></D:prop><D:href>/dav/xxx%40xxxxxx.hu/Calendar/1153cd64-6030-4fdc-b690-86b8e7eb2460.ics</D:href></C:calendar-multiget>

CalDAV: recv: 

<D:multistatus>
  <D:response>
    <D:href>/dav/xxx@xxxxx.hu/Calendar/1153cd64-6030-4fdc-b690-86b8e7eb2460.ics</D:href>
    <D:propstat>
      <D:status>HTTP/1.1 200 OK</D:status>
      <D:prop>
        <C:calendar-data>BEGIN:VCALENDAR
VERSION:2.0
PRODID:Zimbra-Calendar-Provider
BEGIN:VTIMEZONE
TZID:Europe/Budapest
BEGIN:STANDARD
DTSTART:16010101T030000
TZOFFSETTO:+0100
TZOFFSETFROM:+0200
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=10;BYDAY=-1SU
TZNAME:CET
END:STANDARD
BEGIN:DAYLIGHT
DTSTART:16010101T020000
TZOFFSETTO:+0200
TZOFFSETFROM:+0100
RRULE:FREQ=YEARLY;WKST=MO;INTERVAL=1;BYMONTH=3;BYDAY=-1SU
TZNAME:CEST
END:DAYLIGHT
END:VTIMEZONE
BEGIN:VEVENT
UID:1153cd64-6030-4fdc-b690-86b8e7eb2460
SUMMARY:Új esemény
DTSTART;TZID="Europe/Budapest":20131214T114500
DTEND;TZID="Europe/Budapest":20131214T134500
STATUS:CONFIRMED
CLASS:PUBLIC
TRANSP:OPAQUE
LAST-MODIFIED:20131211T210850Z
DTSTAMP:20131211T210850Z
SEQUENCE:0
END:VEVENT
END:VCALENDAR
</C:calendar-data>
        <D:getetag>"364572-364572"</D:getetag>
      </D:prop>
    </D:propstat>
  </D:response>
</D:multistatus>

CalDAV: send(https://mail.pcvilag.hu/dav/xxx%40xxxxxx.hu/Calendar/): <?xml version="1.0" encoding="UTF-8"?>
<sync-collection xmlns="DAV:"><sync-token/><sync-level>1</sync-level><prop><getcontenttype/><getetag/></prop></sync-collection>

CalDAV: webdav-sync Token: null

[JavaScript Warning: "CalDAV: Error doing webdav sync: 403"]

[JavaScript Warning: "Hiba történt a következő naptár adatainak beolvasása közben: Balu. A hiba valószínűleg nem súlyos, ezért a program megpróbál tovább működni. Hibakód: DAV_REPORT_ERROR. Leírás: Hiba történt a következő naptár adatainak beolvasása közben: https://mail.pcvilag.hu/dav/xxx@xxxxxx.hu/Calendar. Le lett tiltva, amíg nem biztonságos a használata."]

[JavaScript Warning: "Hiba történt a következő naptár adatainak beolvasása közben: Balu. A hiba valószínűleg nem súlyos, ezért a program megpróbál tovább működni. Hibakód: READ_FAILED. Leírás: "]

CalDAV: recv: 

CalDAV: onStopRequest: no reader
Lightning 2.6.4 was just released moments ago, please give it a try :)

Comment 8

4 years ago
Finaly the problem is gone with Lightning 2.6.4! 

Thanks!
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 930132
(Reporter)

Comment 10

4 years ago
Work for me too
Philipp, thanks for all
You need to log in before you can comment on or make changes to this bug.