If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows desktop B2G builds are higher priority than Firefox builds

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: RyanVM, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
We had a situation this morning where Windows desktop Firefox builds were lagging by over 3 hours on b2g-inbound while the Desktop B2G builds were all humming along just fine. bhearsum tells me that this is due to how B2G builds are prioritized.

Desktop Firefox builds actually run tests and should always take priority over the B2G builds which are basically run just to make sure they don't break.
I traced this back to https://bugzilla.mozilla.org/show_bug.cgi?id=823642#c0. I have a feeling this was added during a b2g work week. We should probably make them at least equal priority at this point. Catlee?
Flags: needinfo?(catlee)
(Reporter)

Comment 2

4 years ago
Can we differentiate between tests and builds for these purposes?
Absolutely!
(Reporter)

Comment 4

4 years ago
Given that B2G builds and tests run in AWS and capacity is rarely an issue, I don't think we really need to, though. I think we can just kill the special case and call it a day.
Windows b2g builds don't run in AWS though...does that make a difference to you? We could adjust priorities on per-builder type basis, too.
(Reporter)

Comment 6

4 years ago
Non-AWS B2G desktop builds are run at this point only to make sure they still build. The platforms that actually run tests are AWS.
equal priority sounds fine to me
Flags: needinfo?(catlee)
Created attachment 8341841 [details] [diff] [review]
remove b2g special case + fix for bug 945724

I think this addresses this bug and bug 945724.
Attachment #8341841 - Flags: review?(ryanvm)
Attachment #8341841 - Flags: review?(catlee)
(Reporter)

Updated

4 years ago
Attachment #8341841 - Flags: review?(ryanvm) → review+

Updated

4 years ago
Attachment #8341841 - Flags: review?(catlee) → review+
Attachment #8341841 - Flags: checked-in+
Duplicate of this bug: 945724
in production
Hopefully this will help.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.