[lockscreen] Double tap of icon on slider unlocks phone

RESOLVED DUPLICATE of bug 943237

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED DUPLICATE of bug 943237
4 years ago
4 years ago

People

(Reporter: robmac, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
STR
1) Lock phone
2) Turn on phone
3) Double tap the unlock icon or the camera icon

ACTUAL RESULT
Phone unlocks

EXPECTED RESULT
Icons should become brighter on tap, but the slider should only be activated from dragging from the center of the unlock mechanism only.

THE VIDEO
https://mozilla.box.com/s/hplxv5c3na53akjdgx9d
(Reporter)

Comment 1

4 years ago
Steve, let's discuss in the office tomorrow. Thanks!
blocking-b2g: --- → 1.3?
Flags: needinfo?(schung)

Updated

4 years ago
Keywords: regression, regressionwindow-wanted

Comment 2

4 years ago
The regression window is between the 11-27 build and the 12-01 build.

Last Working Build:
Device: Buri v1.3 COM RIL
BuildID: 20131127040203
Gaia: d4b9a3d271f0451b4d903a03c2b931b8cc092041
Gecko: 6ecf0c4dfcbe
Version: 28.0a1

First Broken Build:
Device: Buri v1.3 COM RIL
BuildID: 20131201040201
Gaia: f23aebebcd28c4d19347def77c4836c8baebc2ce
Gecko: 84a5a5800bd3
Version: 28.0a1
Keywords: regressionwindow-wanted
(In reply to Nikolai Khristoforov from comment #2)
> The regression window is between the 11-27 build and the 12-01 build.
> 
> Last Working Build:
> Device: Buri v1.3 COM RIL
> BuildID: 20131127040203
> Gaia: d4b9a3d271f0451b4d903a03c2b931b8cc092041
> Gecko: 6ecf0c4dfcbe
> Version: 28.0a1
> 
> First Broken Build:
> Device: Buri v1.3 COM RIL
> BuildID: 20131201040201
> Gaia: f23aebebcd28c4d19347def77c4836c8baebc2ce
> Gecko: 84a5a5800bd3
> Version: 28.0a1

Can you get the regression range down to a day? There's b2gotoro builds that should allow you to reduce this down to a day.
Keywords: regressionwindow-wanted

Comment 4

4 years ago
The regression range has been narrowed down to between the 11-28 and 11-29 builds.

Last Working Build:
Device: Buri v1.3 COM RIL
BuildID: 20131128040201
Gaia: 0d57ec2801ae125ec855a19cf956ab118660d694
Gecko: a5e7f611546f
Version: 28.0a1

First Broken Build:
Device: Buri v1.3 COM RIL
BuildID: 20131129053350
Gaia: 09d1f63762aaf645b5b6642d218b40f069b77562
Gecko: e9337081c744
Version: 28.0a1
Keywords: regressionwindow-wanted
(In reply to Rob MacDonald [:robmac] from comment #1)
> Steve, let's discuss in the office tomorrow. Thanks!

Since the architecture of lockscreen and incoming call screen is totally different now, Greg might have clear idea about the problem. We can discuss these issues in office for sure!
Flags: needinfo?(schung) → needinfo?(gweng)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(gweng)
Resolution: --- → DUPLICATE
Duplicate of bug: 943237

Updated

4 years ago
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.