Closed Bug 945824 Opened 6 years ago Closed 6 years ago

crash in FireSuccessAsyncTask::~FireSuccessAsyncTask

Categories

(Core :: DOM: Core & HTML, defect, critical)

28 Branch
All
Android
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 934563

People

(Reporter: nhirata, Unassigned)

Details

(Keywords: crash, Whiteboard: [b2g-crash])

Crash Data

This bug was filed from the Socorro interface and is 
report bp-be3ede41-0c5a-4300-b425-9543d2131202.
=============================================================

Crashing Thread
Frame 	Module 	Signature 	Source
0 	libxul.so 	FireSuccessAsyncTask::~FireSuccessAsyncTask 	dom/base/DOMRequest.cpp
1 	libxul.so 	FireSuccessAsyncTask::~FireSuccessAsyncTask 	dom/base/DOMRequest.cpp
2 	libxul.so 	AsyncLatencyLogger::Release() 	content/media/Latency.cpp
3 	libxul.so 	IPC::Principal::~Principal 	/builds/slave/b2g_m-cen_inari_ntly-000000000/build/objdir-gecko/ipc/ipdl/../../dist/include/nsCOMPtr.h
4 	libxul.so 	nsThread::ProcessNextEvent(bool, bool*) 	/builds/slave/b2g_m-cen_inari_ntly-000000000/build/objdir-gecko/xpcom/threads/../../dist/include/nsCOMPtr.h
5 	libxul.so 	NS_ProcessNextEvent(nsIThread*, bool) 	xpcom/glue/nsThreadUtils.cpp
6 	libxul.so 	mozilla::ipc::MessagePump::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
7 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
8 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
9 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
10 	libxul.so 	nsBaseAppShell::Run() 	widget/xpwidgets/nsBaseAppShell.cpp
11 	libxul.so 	XRE_RunAppShell 	toolkit/xre/nsEmbedFunctions.cpp
12 	libxul.so 	mozilla::ipc::MessagePumpForChildProcess::Run(base::MessagePump::Delegate*) 	ipc/glue/MessagePump.cpp
13 	libxul.so 	MessageLoop::RunInternal() 	ipc/chromium/src/base/message_loop.cc
14 	libxul.so 	MessageLoop::Run() 	ipc/chromium/src/base/message_loop.cc
15 	libxul.so 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp
16 	plugin-container 	main 	ipc/app/MozillaRuntimeMain.cpp
17 	libc.so 	__libc_init 	bionic/libc/bionic/libc_init_dynamic.c
18 		@0xb0001dc5
FYI looks like an Async crash.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934563
Flags: needinfo?(milan)
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.