TB "Features" web page had 3 identically labelled links (need OS differentiation added)

RESOLVED WORKSFORME

Status

www.mozilla.org
Thunderbird
RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: Dan Gawarecki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8341898 [details]
TB-Features_Labels_lack_OS_differentation.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

Start FireFox v25.0.1,  Enter into address the URL of http://www.mozilla.org/en-US/thunderbird/features/


Actual results:

Observe 3 links, stacked vertically, under the "Get more out of Thunderbird!".  All 3 links are the same text of:  "Thunderbird Free Download".  (See attachment)

The associated links (URLs) are:  
1.  http://www.mozilla.org/en-US/thunderbird/download/?product=thunderbird-24.1.1&os=win&lang=en-US
2.  http://www.mozilla.org/thunderbird/download/?product=thunderbird-24.1.1&os=linux&lang=en-US
3.  http://www.mozilla.org/thunderbird/download/?product=thunderbird-24.1.1&os=osx&lang=en-US 


Expected results:

I think the links should have the OS appearing in the link title; e.g., "Thunderbird Free Download - Windows",

Comment 1

4 years ago
I'm getting the "Blocked loading mixed active content" warning from
<script src="http://www.mozilla.org//media/js/site-min.js?build=fe720c2"></script>
which is responsible for identifying the platform.

Changing this to a relative or https: link should resolve the issue.
Status: UNCONFIRMED → NEW
Component: Untriaged → Thunderbird
Ever confirmed: true
Product: Thunderbird → www.mozilla.org

Comment 2

4 years ago
I agree that it is a bad idea for all three links to have the same link text.  They should be distinct from each other.
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 3

4 years ago
The design is to show just a single link, matching the platform from which the page is accessed with. After the introduction of the new mixed-content blocker (bug 62178, enabled with bug 834836 for Firefox and bug 864369 for SeaMonkey), constructs like the one mentioned in comment #1 are now blocked, thus the script is never executed and all links remain visible.

However, even with security.mixed_content.block_active_content set to false still all three lines are shown, thus something else seems to be contributing to the issue as well.
I believe this is now working fine.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.