Closed Bug 945917 Opened 8 years ago Closed 8 years ago

Build broken with --disable-webrtc

Categories

(Core :: Audio/Video, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 945859

People

(Reporter: avih, Assigned: rillian)

References

Details

Probably from bug 763495

End of the build log on OS X 10.9:

[...]

 1:42.24 XUL
 1:46.20 Executing: /usr/local/bin/ccache clang++ -Qunused-arguments -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wsign-compare -Wno-invalid-offsetof -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-mismatched-tags -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -std=gnu++0x -pthread -DNO_X11 -pipe -DNDEBUG -DTRIMMED -g -O3 -fno-omit-frame-pointer -fPIC -o XUL -Wl,-filelist,/Users/avih/dev/moz/src/m-c/obj-ff-dbg/toolkit/library/tmpd3zCIP.list -framework Cocoa -lobjc -framework ExceptionHandling -Wl,-executable_path,/Users/avih/dev/moz/src/m-c/obj-ff-dbg/dist/bin -Wl,-dead_strip ../../xpcom/typelib/xpt/src/libxpt.a ../../intl/unicharutil/util/internal/libintl_unicharutil_util_internal.a -L../../dist/bin -L../../dist/lib ../../dist/lib/libjs_static.a -L../../dist/bin -L../../dist/lib -lcrmf -lsmime3 -lssl3 -lnss3 -lnssutil3 ../../dist/lib/libmozsqlite3.dylib -L../../dist/bin -L../../dist/lib -L/Users/avih/dev/moz/src/m-c/obj-ff-dbg/dist/lib -lnspr4 -lplc4 -lplds4 ../../dist/lib/libmozalloc.dylib -dynamiclib -install_name @executable_path/XUL -compatibility_version 1 -current_version 1 -single_module -L/Users/avih/dev/moz/src/m-c/obj-ff-dbg/dist/lib -lmozglue -framework OpenGL -lcups -framework SystemConfiguration -framework QTKit -framework IOKit -F/System/Library/PrivateFrameworks -framework CoreUI -framework CoreLocation -framework QuartzCore -framework Carbon -framework CoreAudio -framework AudioToolbox -framework AudioUnit -framework AddressBook -framework OpenGL
 1:46.20 /Users/avih/dev/moz/src/m-c/obj-ff-dbg/toolkit/library/tmpd3zCIP.list:
 1:46.20     nsStaticXULComponents.o
 1:46.20     ../../media/kiss_fft/kiss_fft.o
 1:46.20     ../../media/kiss_fft/kiss_fftr.o
 1:46.20     ../../xpcom/build/mach_override.o
 1:46.20     ../../xpcom/build/PoisonIOInterposerBase.o
 1:46.20     ../../xpcom/build/PoisonIOInterposerMac.o
 1:46.20     ../../xpcom/build/FileLocation.o
 1:46.20     ../../xpcom/build/Omnijar.o
 1:46.20     ../../xpcom/build/Unified_cpp_xpcom_build0.o

[...]

 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia5.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia6.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia7.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia8.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia9.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia10.o
 1:46.80     ../../gfx/skia/Unified_cpp_gfx_skia11.o
 1:46.81     ../../gfx/skia/Unified_cpp_gfx_skia12.o
 1:46.81     ../../gfx/skia/Unified_cpp_gfx_skia13.o
 1:46.81     ../../gfx/skia/Unified_cpp_gfx_skia14.o
 1:46.81     ../../gfx/skia/Unified_cpp_gfx_skia15.o
 1:46.81     ../../gfx/skia/Unified_cpp_gfx_skia16.o
 1:46.81 
 1:46.81 ld: warning: could not create compact unwind for _ffi_call_unix64: does not use RBP or RSP based frame
 1:46.81 Undefined symbols for architecture x86_64:
 1:46.81   "_vp8_full_search_sad_c", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_full_search_sadx3", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_regular_quantize_b_sse2", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_diamond_search_sadx4", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_refining_search_sad_c", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_regular_quantize_b_sse4", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_diamond_search_sad_c", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_refining_search_sadx4", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.81   "_vp8_full_search_sadx8", referenced from:
 1:46.81       _setup_rtcd_internal in rtcd.o
 1:46.82   "_vp8_fast_quantize_b_sse2", referenced from:
 1:46.82       _setup_rtcd_internal in rtcd.o
 1:46.82   "_vp8_fast_quantize_b_ssse3", referenced from:
 1:46.82       _setup_rtcd_internal in rtcd.o
 1:46.82 ld: symbol(s) not found for architecture x86_64
 1:46.82 clang: error: linker command failed with exit code 1 (use -v to see invocation)
 1:46.82 make[5]: *** [XUL] Error 1
 1:46.82 make[4]: *** [toolkit/library/libs] Error 2
 1:46.82 make[3]: *** [libs] Error 2
 1:46.82 make[2]: *** [default] Error 2
 1:46.82 make[1]: *** [realbuild] Error 2
 1:46.82 make: *** [build] Error 2
 1:46.84 226 compiler warnings present.
Seeing the same on OpenBSD, where webrtc isnt ready for public availability and is thus disabled in my builds.

http://buildbot.rhaalovely.net/builders/mozilla-central-amd64/builds/960

: In function `setup_rtcd_internal':
/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:716: undefined reference to `vp8_full_search_sadx3'
../../media/libvpx/rtcd.o(.text+0xe5):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:716: undefined reference to `vp8_full_search_sad_c'
../../media/libvpx/rtcd.o(.text+0x109):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:699: undefined reference to `vp8_regular_quantize_b_sse2'
../../media/libvpx/rtcd.o(.text+0x115):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:717: undefined reference to `vp8_full_search_sadx8'
../../media/libvpx/rtcd.o(.text+0x161):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:720: undefined reference to `vp8_refining_search_sad_c'
../../media/libvpx/rtcd.o(.text+0x168):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:723: undefined reference to `vp8_diamond_search_sad_c'
../../media/libvpx/rtcd.o(.text+0x1ef):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:723: undefined reference to `vp8_diamond_search_sadx4'
../../media/libvpx/rtcd.o(.text+0x1ff):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:720: undefined reference to `vp8_refining_search_sadx4'
../../media/libvpx/rtcd.o(.text+0x2db):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:699: undefined reference to `vp8_regular_quantize_b_sse4'
../../media/libvpx/rtcd.o(.text+0x3a4):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:702: undefined reference to `vp8_fast_quantize_b_ssse3'
../../media/libvpx/rtcd.o(.text+0x3ab):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vpx_rtcd_x86_64-linux-gcc.h:702: undefined reference to `vp8_fast_quantize_b_sse2'
../../media/libvpx/temporal_filter.o(.text+0x15b)/usr/bin/ld: Dwarf Error: Invalid or unhandled FORM value: 25.

: In function `vp8_temporal_filter_prepare_c':
/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:450: undefined reference to `vp8_lookahead_depth'
../../media/libvpx/temporal_filter.o(.text+0x236):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:507: undefined reference to `vp8_lookahead_peek'
../../media/libvpx/temporal_filter.o(.text+0x5f7):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:191: undefined reference to `vp8_hex_search'
../../media/libvpx/temporal_filter.o(.text+0x887):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:332: undefined reference to `vp8_temporal_filter_apply_sse2'
../../media/libvpx/temporal_filter.o(.text+0x8c5):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:342: undefined reference to `vp8_temporal_filter_apply_sse2'
../../media/libvpx/temporal_filter.o(.text+0x8fb):/var/buildslave-mozilla/mozilla-central-amd64/build/media/libvpx/vp8/encoder/temporal_filter.c:352: undefined reference to `vp8_temporal_filter_apply_sse2'
/usr/bin/ld: libxul.so.1.0: hidden symbol `vp8_regular_quantize_b_sse4' isn't defined
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 945859
You need to log in before you can comment on or make changes to this bug.