At end of reftest runs: /bin/sh: 1: Syntax error: ";" unexpected

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dholbert, Assigned: glandium)

Tracking

Trunk
mozilla28
x86_64
Linux
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

I'm seeing this at the end of my local (successful) reftest runs:

 1:13.00 TEST-PASS | leakcheck | no leaks detected!
 1:13.00
 1:13.00 REFTEST INFO | runreftest.py | Running tests: end.
 1:13.01 /bin/sh: 1: Syntax error: ";" unexpected
 1:13.01 make: *** [reftest] Error 2 

hg bisect says it started with bug 943728 (though without the followup cset there, it looks like this instead:

 0:23.89 TEST-PASS | leakcheck | no leaks detected!
 0:23.89
 0:23.89 REFTEST INFO | runreftest.py | Running tests: end.
 0:23.90 reftest failed:
 0:23.90 $errors
 0:23.90 make: *** [reftest] Error 1
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
I confirmed that this fixes the issue for me, so I pushed the patch (at glandium's suggestion):
 https://hg.mozilla.org/integration/mozilla-inbound/rev/aa8f820b458f
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/aa8f820b458f
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.