Filter collections apps by device type in addition to buchets

RESOLVED INVALID

Status

P2
normal
RESOLVED INVALID
5 years ago
4 years ago

People

(Reporter: dbialer, Unassigned)

Tracking

x86
Mac OS X
Points:
---

Details

(Whiteboard: dogfood1.2)

(Reporter)

Description

5 years ago
Contactzilla is showing up as a featured app on Firefox OS.  It is listed as Desktop and Tablet.  So the install button is grayed out.  It should not show up.

Steps to reproduce:
1. View all featured apps on a Firefox OS phone.  In the apps list you will be Contactzilla.  According to the DB it is only for desktop and tablet.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 919780
(Reporter)

Comment 2

5 years ago
It seems this is the opposite of Bug 91978 - where the bug is that they are getting filtered.  In this case, it should be filtered, but isn't?  no?

Updated

5 years ago
Component: Consumer Pages → API
(Reporter)

Comment 3

5 years ago
Just reopened to clarify this.  We should be buchet filtering featured apps on mobile.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

5 years ago
> We should be buchet filtering featured apps on mobile.

We are buchet filtering; the apps you're seeing aren't being filtered by device type.
(Reporter)

Comment 5

5 years ago
Then the issue must be with buchet filtering as Contactzilla is a desktop app but appears on a mobile device though it is not compatible and of no interest to a mobile user.  Shouldn't we not show apps that are incompatible?  Otherwise you get all these irrelevant apps showing up.  There really isn't a strong use case for mobile users wanting to see (desktop) apps that don't work.

Comment 6

5 years ago
According to the data coming from the API:

- Contactzilla is marked as desktop and android tablet-compatible (the big checkboxes)
- The only version of Contactzilla on the Marketplace has no minimum requirements set (the buchets)

https://marketplace.firefox.com/app/contactzilla?src=search

This is not related to buchets, it is device type filtering.
Indeed, we don't do device type filtering in collections API at the moment, only buchets (and only for firefox os / android users, like on the rest of the APIs).
Summary: Non Firefox OS apps showing up in Featured Apps on Firefox OS → Filter collections apps by device type in addition to buchets

Comment 8

5 years ago
So everyone is aware, for now I will not select desktop-only apps to be one of the top three featured apps in any given category (top three being the distinction because the user sees the top three featured apps upon firing up the Marketplace but must proactively navigate into a collection to get the full list).
Whiteboard: dogfood1.2
Priority: -- → P2

Updated

5 years ago
Assignee: nobody → mpillard

Updated

4 years ago
Assignee: mpillard → nobody
Blocks: 1032972
No longer blocks: 1032972
Resolving as invalid because feed made old-style collections obsolete and supports device filtering.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.