[ZTE] [APN] - APN network issue when update to 1.1 navigation issues

RESOLVED INCOMPLETE

Status

Firefox OS
Gaia
RESOLVED INCOMPLETE
5 years ago
5 years ago

People

(Reporter: guigs [guigs] PST (please needinfo me!), Assigned: jaoo)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:koi+)

Details

(Whiteboard: [SUMO-b2g])

Hi, 

I just wanted to give you heads up for a possible escalation from TEF Peru&Colombia. It seems that lately they had more than 50% of their support calls in relation to navigation issues - APN setup. We might deal with a misconfiguration of the APN as customers complain about not being able to access internet. As soon as the customer care agent brings them to the APN screen the issue gets solved. TEF thinks that the system refreshes itself when accessing the APN screen and this is necessary for the internet to work. They are testing it today in house and if this theory proves true they will escalate it asap.


STEPS TO REPRODUCE:
1. Have any product phone from Columbia or Peru
2. Update to 1.1 and not have internet connectivity
3. customer care agent brings them to the APN screen the issue gets solved.
4. Manually enter the internet and it begins to work
5. 

EXPECTED RESULTS:

ACTUAL RESULTS:
no internet connection after update



Please let me know if there is any information I could provide to help with the investigation and troubleshooting of this issue.

Thanks!!
What I think is happening here is that we are losing APN data on a FOTA update, which then leads to the loss of internet connection due to not having a data connection. The customer agent then fixes this APN settings on the phone, which fixes the data connection. The user can then connect to the internet.

Gene - Any thoughts here?

I'm marking qawanted here to see if we can reproduce this on an update from 1.01 to 1.1.
blocking-b2g: --- → koi?
Flags: needinfo?(gene.lian)
Keywords: qawanted
I have no idea by far. V1.1 is already a bit far away from me. Keep my needinfo to keep track of and CC'ing Ken as well.

If my recall is right, Ken used to fix some APN settings issues around the time points after branching V1.1.

Starting with qawanted will definitely be useful. Thanks QA very much!

Comment 3

5 years ago
It is strange that data call is working after reset the configuration.
I will also check it and CC'ing Jose, he may have some ideas.
Thanks a lot for reporting the issue, we will investigate it in our side as well. Let me try to clarify the part of the description that does not fit with the commercial scenario:
Peru - ZTE v1.1
Colombia - started with ZTE v1.0.1 and then update their customers to v1.1

The other vendor that you mentioned in the title of the bug had not luanched commercially in any of those countries.
IMHO, we should investigate the issue with ZTE device first and starting with version 1.1. The first time I heard about this issue it was related to Peru where no FOTA had been deployed.
(In reply to Beatriz Rodríguez [:brg] from comment #4)
> Thanks a lot for reporting the issue, we will investigate it in our side as
> well. Let me try to clarify the part of the description that does not fit
> with the commercial scenario:
> Peru - ZTE v1.1
> Colombia - started with ZTE v1.0.1 and then update their customers to v1.1
> 
> The other vendor that you mentioned in the title of the bug had not luanched
> commercially in any of those countries.
> IMHO, we should investigate the issue with ZTE device first and starting
> with version 1.1. The first time I heard about this issue it was related to
> Peru where no FOTA had been deployed.

Hmm okay. So it might not be related to FOTA then.

Leaving QA Wanted to test this on a 1.1 ZTE Peru partner build.

Updated

5 years ago
Keywords: regression
koi+ as it seems to be severe enough for koi as well.
blocking-b2g: koi? → koi+
Keywords: regression
Summary: [ZTE/ LGl] [APN] - APN network issue when update to 1.1 navigation issues → [ZTE] [APN] - APN network issue when update to 1.1 navigation issues
Whiteboard: [SUMO-b2g]
Beatriz,

Any updates here? Has the investigation concluded?
Flags: needinfo?(brg)
Ken

Are you working this bug? If yes, please own the bug, else please reassign appropriately
Flags: needinfo?(kchang)
(Assignee)

Comment 9

5 years ago
I'll take care of it.
Assignee: nobody → josea.olivera

Comment 10

5 years ago
José have taken this bug. Thanks, José.
Flags: needinfo?(kchang)
I have got some more information: 
What are the steps to reproduce?

After the FTU (device first use) the user can´t connect to the internet until they open the APN settings screen in "Settings"

What was the actual behavior?:
The user can´t reach any internet site using the browser.
What was the expected behavior?:

Browse the web.

Build and GIT commit number

20130923212708
2013-09-23 13:15:52
Flags: needinfo?(gene.lian)
Flags: needinfo?(brg)
(In reply to rmcguigan from comment #0)
> Please let me know if there is any information I could provide to help with
> the investigation and troubleshooting of this issue.

Could you provide the information below please?
- How did you manage to update to v1.1.
- Device.
- MCC and MNC in the ICC card you are using.
- Country where it happens.

Thanks!
Flags: needinfo?(rmcguigan)
- Countries that reported it was Peru and Columbia
- Device is  ZTE with a preloaded 1.1 

This build they are trying to reproduce: 
20130923212708 2013-09-23 13:15:52

The Perú devices are preloaded with 1.1

Steps trying to reproduce
1. After the FTU (device first use) the user can´t connect to the internet until they open the APN settings screen in "Settings"
2The user can´t reach any internet site using the browser.
Flags: needinfo?(rmcguigan)
Note for QA Wanted - try testing by doing an update from 1.1 to 1.2 using a Leo device.

Comment 15

5 years ago
Unable to reproduce after OTA from 1.1 to 1.2 on Leo in the US. After the OTA was performed, internet and data worked properly. Likely a country specific issue.
Keywords: qawanted
We had tried to reproduce in Spain with our support team and we did not reproduce it. The lack of useful information(logs) in this bug since we opened it plus the difficult to reproduce it make me think that it seems to be a bad rumor.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Moving to incomplete - incomplete is used in the case where we've exhausted efforts to be able to make this actionable.
Resolution: WORKSFORME → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.