click-hold on dock icon can cause crash

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: Bill McGonigle (not currently reading bugmail; please contact directly), Assigned: Paul Chen)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

This isn't easily reproducible, but it did occur.  I didn't have any windows
open at the time (I was going to select quit).

**********

Date/Time: 2001-08-09 18:35:00 -0400

PID:       312
Command:   Mozilla

Exception: EXC_BAD_ACCESS (0x0001)
Codes:     KERN_PROTECTION_FAILURE (0x0002) at 0x000000a4

Thread 0:
 #0   0x73878c20 in _GetPlatformWindow__10WindowData ()
 #1   0x000455b4 in 0x455b4 ()
 #2   0x738f4a2c in _CreateWindowMenuForDock ()
 #3   0x73841670 in _DockCallback__FUlP18OpaqueCoreDockItemPvn1 ()
 #4   0x74702fc4 in _ClientMessageHandler ()
 #5   0x701a0b14 in ___CFMessagePortPerform ()
 #6   0x7018d7c4 in ___CFRunLoopDoSource1 ()
 #7   0x7017ac34 in ___CFRunLoopRun ()
 #8   0x7017a56c in _CFRunLoopRunInMode ()
 #9   0x737dc470 in _RunEventLoopInModeUntilEventArrives ()
 #10  0x7383afd4 in _RunEventLoopUntilEventArrives ()
 #11  0x7383addc in _GetNextEventMatchingMask ()
 #12  0x7383aacc in _WNEInternal ()
 #13  0x7383a988 in _WaitNextEvent ()
 #14  0x01a87d34 in GetEvent__16nsMacMessagePumpFR11EventRecord ()
 #15  0x01a87844 in DoMessagePump__16nsMacMessagePumpFv ()
 #16  0x01a870e8 in Run__10nsAppShellFv ()
 #17  0x018191f4 in Run__17nsAppShellServiceFv ()
 #18  0x00093dfc in main1__FiPPcP11nsISupports ()
 #19  0x00094b6c in main ()

Thread 1:
 #0   0x7000424c in _syscall ()
 #1   0x706584b8 in _ProcessReadyEvent ()
 #2   0x706582b0 in _CarbonSelectThreadFunc ()
 #3   0x70014f04 in __pthread_body ()

Thread 2:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x70653be0 in _BSD_pthread_cond_wait ()
 #5   0x70653bc0 in _CarbonConditionWait ()
 #6   0x7065557c in _CarbonOperationThreadFunc ()
 #7   0x70014f04 in __pthread_body ()

Thread 3:
 #0   0x70059b48 in _semaphore_timedwait_signal_trap ()
 #1   0x7003f7f8 in _semaphore_timedwait_signal ()
 #2   0x70015f68 in __pthread_cond_wait ()
 #3   0x7003f7c4 in _pthread_cond_timedwait_relative_np ()
 #4   0x7029b590 in _TSWaitOnConditionTimedRelative ()
 #5   0x7029cdac in _TSWaitOnSemaphoreCommon ()
 #6   0x702e5f98 in _TSWaitOnSemaphoreRelative ()
 #7   0x702e7208 in _TimerThread ()
 #8   0x70014f04 in __pthread_body ()

Thread 4:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x7029b550 in _TSWaitOnCondition ()
 #5   0x7029cd94 in _TSWaitOnSemaphoreCommon ()
 #6   0x7029cce4 in _TSWaitOnSemaphore ()
 #7   0x7029cba8 in _AsyncFileThread ()
 #8   0x70014f04 in __pthread_body ()

Thread 5:
 #0   0x70059b68 in _semaphore_wait_signal_trap ()
 #1   0x70016110 in _semaphore_wait_signal ()
 #2   0x70015f78 in __pthread_cond_wait ()
 #3   0x70015d18 in _pthread_cond_wait ()
 #4   0x70653be0 in _BSD_pthread_cond_wait ()
 #5   0x70653bc0 in _CarbonConditionWait ()
 #6   0x70653ab4 in _CarbonInetOperThreadFunc ()
 #7   0x70014f04 in __pthread_body ()

Thread 6:
 #0   0x700007b8 in _mach_msg_overwrite_trap ()
 #1   0x700056e4 in _mach_msg_overwrite ()
 #2   0x700277b0 in _thread_suspend ()
 #3   0x70027744 in __pthread_become_available ()
 #4   0x70027468 in _pthread_exit ()
 #5   0x70014f08 in __pthread_body ()

PPC Thread State:
  srr0: 0x73878c20 srr1: 0x0000d030                vrsave: 0x00000000
   xer: 0x2000000c   lr: 0x738f4a38  ctr: 0x70161e6c   mq: 0x00000000
    r0: 0x00000000   r1: 0xbfffed40   r2: 0x738929c0   r3: 0x00000000
    r4: 0x00000000   r5: 0x0000000c   r6: 0x00000020   r7: 0x00000000
    r8: 0x766c2e7f   r9: 0x00000000  r10: 0xbfffecf8  r11: 0x22000004
   r12: 0x70161e6c  r13: 0x00000000  r14: 0x00000000  r15: 0x00000000
   r16: 0x00000000  r17: 0x00000000  r18: 0x00000000  r19: 0x00000000
   r20: 0x00000001  r21: 0x00000000  r22: 0x80160208  r23: 0x00000000
   r24: 0x00000000  r25: 0x00000000  r26: 0x00000000  r27: 0x0000002f
   r28: 0x020ef8c8  r29: 0x00000000  r30: 0xbfffed40  r31: 0x738f4960

**********
hm, couldn't repro on 10.0.4 using 2001.08.09.08-comm bits. is this still a
problem for you with more recent bits? if so, do reopen...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Well, I mentioned that this isn't easily reproducible, so a first try isn't likely to crash.  Has the code handling this menu changed in the past 2 days?  If it hasn't I don't think this bug should be closed so nonchalantly.  If it has, then that might make sense.
steve/pink, could you answer bill's question?

Comment 5

17 years ago
pink is the menu wiz so I'll defer to him but looking at the stack crawl it looks 
to me we crashed in Apple code rather than Mozilla code.
yeah, it looks like a bug in the dock. we don't have any dock code in our app.
mass verification of WorksForMe bugs: to find all bugspam pertaining to this,
set your search string to "IfItWorksForSlappyTheSquirrelThenItWFM".

if you think this particular bug is *still* an open issue, please make sure of
the following before reopening:

a. that it's still a problem with ***recent trunk builds*** on the all
appropriate platform[s]

b. provide clear steps to reproduce (unless a good test case is already in the
bug report), making sure it pertains to the original problem (avoid morphing as
much as possible :)
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.