popups opened via script don't set document.popupNode

VERIFIED INVALID

Status

()

VERIFIED INVALID
17 years ago
10 years ago

People

(Reporter: hewitt, Assigned: hewitt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

17 years ago
When popups are opened via nsXULPopupListener, the document.popupNode property
is set to indicate the element that was the target of the popup.  However, if
you open a popup via nsIPopupSetBoxObject::createPopup, this property will not
be set.  

This has the side effect of causing said popups to be occasionally mis-aligned,
because nsMenuPopupFrame uses the document.popupNode property to get the widget
of the target document in order to calculate screen coordinates for positioning
the popup.

I suspect this may also be the cause of the bug that causes the autocomplete
popup to be painted in the wrong place.

Patch forthcoming...
(Assignee)

Comment 1

17 years ago
Created attachment 45312 [details] [diff] [review]
patch to fix
(Assignee)

Comment 2

17 years ago
reviews anyone?
Status: NEW → ASSIGNED
Summary: popups opened via script don't set document.popupNode → popups opened via script don't set document.popupNode
(Assignee)

Comment 3

17 years ago
nevermind, found a better way to do this. invalid.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 4

17 years ago
Make it so.
Status: RESOLVED → VERIFIED
so does this 'better way to do it' fix the problem where the autocomplete would 
come up at the wrong place when it didn't have any completions?

Updated

10 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.