Unable to log in to login.paas.allizom.org

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jgmize, Assigned: cturra)

Tracking

Details

(Reporter)

Description

4 years ago
I am having the same problems as Giorgos, who I will quote from his email to the paas mailing list:

Since the dev paas migration (thanks Chris!) I'm unable to login to web
console

https://login.paas.allizom.org/

I tried with a clean Firefox Profile and I get redirected to

https://login.paas.allizom.org/openid/complete

with this error

'The login request could not be completed. Please ensure that you have
cookies enabled in your browser and that your system clock is set to the
correct time.'

I'm able to login with stackato client.
(Assignee)

Comment 1

4 years ago
looking into it now.
Assignee: server-ops-webops → cturra
Status: NEW → ASSIGNED
OS: Linux → All
Hardware: x86_64 → All
(Assignee)

Comment 2

4 years ago
i think i have it sorted out now - just having :solarce and a couple others test for me (if you're copied on this email, feel free to test also).

i made a couple changes here:

1. login.paas.allizom.org was missing in DNS so was using the *.paas.allizom.org DNS record
2. we had two zlb interfaces api.paas.allizom.org and paas.allizom.org which i believe may have not been sharing session info correctly. to match how i deployed the prod paas, i made these use the same zlb interface (and free up a public ip).
Works for me now, had to clear cookies in Firefox, worked right away in Safari
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Confirmed WFM. Thanks :cturra!
You need to log in before you can comment on or make changes to this bug.